Cannot access website on OR 2.5 controller

Hello,

I have installed with the manual OR 2.5 controller on Raspbian Jessy. When I run the ./openremote.sh start I gives me this error:

Could not find a controller definition to load at path ‘…/webapps/controller/controller.xml’ (for version 2.0)

INFO 2016-06-27 19:05:20,371 : Controller Definition File Watcher for Default Deployer started.

Jun 27, 2016 7:05:21 PM org.restlet.engine.connector.HttpClientHelper start

INFO: Starting the internal HTTP client

Jun 27, 2016 7:05:22 PM org.apache.coyote.http11.Http11Protocol start

INFO: Starting Coyote HTTP/1.1 on http-8688

Jun 27, 2016 7:05:22 PM org.apache.catalina.startup.Catalina start

INFO: Server startup in 8066 ms

INFO 2016-06-27 19:05:24,972 : Unable to retrieve controller identity, retrying in 1,000 milliseconds…

if I try to access the webpage (while the process is running) I don’t open anything. (localhost:8080/controller)

What am I doing wrong? I am really new to OR and cannot find what I am doing wrong.

thanks for the great work!

regards,

REmco

I was using the wrong port…

one other question. I am using the iPhone and created in the online designer a iPhone panel. The panel is working great on the iPhone, but I cannot access the setting screen anymore of the app. How can I access this?

You can shake the device to access the settings.
Or create a button which opens settings.

For everyone else who asks the same question.

The default port for OpenRemote Pro is 8688

So to access the controller from the same machine, the URL would look like this:-

http://localhost:8688/controller

the webconsole can be accessed using this URL

http://localhost:8688/webconsole

With regard to this:

INFO 2016-06-27 19:05:24,972 : Unable to retrieve controller identity, retrying in 1,000 milliseconds…

I am getting this too. Anyone know how to fix this? Is it important?

There are already a number of replies to this question.

I changed the security setting to save the login details to plain text, which seemed to solve it for me.

That’s great Stuart! Where exactly do you change login details?

okay, found where to change .keystore to .plaintext

in …\OpenRemote2p5p0\webapps\controller\WEB-INF\config.properties