DateTime protocol

Hi, I'm using pro 2.5 on a pi3 and Android on a Nexus 7. I'm trying to get the date and time to show. I've followed the How to, even copied the exact settings,but all that's shown is N/A.

Has anyone has this before?



I had a little problem getting my head around the date and time protocol, but once the penny dropped it has worked really well since.

Can you show us the text you've putting into the commands?

And maybe be precise about how you've set up the sensor.

If it helps, I started with a really basic date and time command, without any formatting, then linked it to a custom sensor, just so that I could confirm it was working and to get a feel for the output.

Are you trying to do too much to start with?

Or, have you linked the command to the wrong type of sensor?

Hi, yeah i should have posted this too.

Both sensors are of type ‘custom’, but the values are left blank.

I then created two labels on my layout (time & date), and attached each sensor to the correct label.

I’ve made sure I saved the layout and sync’d it locally. The Android version i’m using is v2.3.0 if that makes any difference.



Hello Charlie,

I'm no expert on this, so hopefully someone else will step in and help you out a little more.

When I was first starting, Michal very kindly put this link up, which contains a table of acceptable codes to use in the format section.

If it helps, here is the text that I have in my time and date command

Latitude : 52.243194
Longitude : 0.884563
Timezone : Europe/London
Command : date
Format: EE dd MMM HH:mm
Polling : 1m

I'm not sure if the Longitude & Latitude are required, but it works for me.

Richard suggested simply dropping a pin on Google maps to get the correct details in the correct format.

Please let us know how you get on.



Hi Stuart, thanks for the example but this also isn’t working for me.

If it makes a difference, i’m running Raspbian Jessie and java 8?



Now there's a thought.

Someone else will need to clarify this, but could it be an issue with Java 1.8?

We know that Drules doesn't play nicely with Java 1.8, so is there a chance that the date & time protocol doesn't like it either.

Can you try Java 1.6 SDK?

I downgraded to Java 7 JDK as i couldn’t find java 6 for Jessie but it’s still the same i’m afraid.

I think i’m gonna give up on the DateTime Protocol. I set up an HTTP request from my NodeRed system, that seems to be working ok for now.

Cheers for your help,