Password with alias '[name]' could not be retrieved, possibly due to incorrect protection password: no match was not found....


I am seeing this error in my boot.log:

TRACE 2016-06-17 13:20:52,884 : Unable to retrieve controller identity

org.openremote.controller.exception.ConnectionException: The required password for user ‘[my designer name]’ was not found. Password manager error : Password for user ‘$PasswordNotFoundException: Implementation Error: password alias ‘[my designer password]’ does not correspond to secret key entry in the keystore.’ was not found

at org.openremote.controller.service.BeehiveCommandCheckService$BeehiveCommandChecker.connect(Unknown Source)

at org.openremote.controller.service.BeehiveCommandCheckService$BeehiveCommandChecker.httpRequest(Unknown Source)

at org.openremote.controller.service.BeehiveCommandCheckService$BeehiveCommandChecker.httpPost(Unknown Source)

at org.openremote.controller.service.BeehiveCommandCheckService$BeehiveCommandChecker.getControllerIdentity(Unknown Source)

at org.openremote.controller.service.BeehiveCommandCheckService$BeehiveCommandChecker.getRemoteCommandService(Unknown Source)

at org.openremote.controller.service.BeehiveCommandCheckService$ Source)


Raspberry Pi 3



I also installed the Java Cryptography Extension for java8.

I removed the .user and .keystore from the controller folder and re-synced from the designer, as suggested somewhere else.

Any idea on what I can start checking?



I am having the exact same issue, I’ve tried both the 2.5 and 2.6 A1 controllers with no luck. Also tried the Crypto extension, no luck.

Anyone got any suggestions?