Question on starting Velbus and Openremote


I have a question about the first connection between Velbus en Openremote.

In short:I can not connect from an app to the openremote controller. Or I can not start the openremote controllor. What to do?

Long version:

Since 2 years I have a working Velbus system.

I have a VMBRSUSB and a VMBHIS to connect from PC or wherever,

Know I want to make my own server and use Openremote

I followed these instruction:

This means:

On a windows XP version I have installed thee ORC from download center (when you login)

I have installed Java SE Development Kit 7u80

I made an environemntal (System!) variable with JAVA_HOME and C:\Program Files\Java\jdk1.7.0_80 (not with the (pre)addition set JAVA_HOME as it says in the tutorial, because that did not work)

I use Golfy’s PB_Velbus server 3.2.exe

That server works. It shows that data on the Velbus. It shows when someone tries to make contact.

I can make contact with velbus via my home network from another PC to Velbus with software VelbusLink

In I changed the Velbus Port and ip adress configuration in the Velbus tab

I made a test butten with the right configuration on a panel Designer.

But :

  • when I try to test in Designer via UI Test link, it only shows OK

  • when I try to connect via the openremote app, it cannot make contact with the server

  • when I run openremote.bat run . is shows the data attached to this post.

  • when I go to http://localhost:8688/controller is doesnt show anything

So , maybe a rookie mistake, but can someone help me?

Cmd file.txt (8.17 KB)

Hello Richard,

Welcome to the world of OpenRemote with Velbus :slight_smile:

Please excuse the short answer, I'm supposed to be heading to a party, I'll reply again.

To get you going..

I don't think the online test function will ever be able to simulate your own Velbus network, so an Okay is the best you can hope for.

The only way to really see if your design works is to sync it with your local controller, so let's address that first :slight_smile:

(This might need the assistance of someone wiser than me on this subject)

As your using PB_Server, the default Velbus settings in OR should be fine

So you just need to get your controller up and running.

What messages do you get when you run the "openremote.bat run" command line?

Good luck,


The clue is in the console output you have provided; address is already in use, do you have something else using port 8688 on your machine?

Good point Richard,

I also noticed that the port is being referenced is 8445.

Curiously, that is the same port that HomeCenter uses.

Is it a case that the default port of OpenRemote has been changed?

Good luck,


Thank you Stuart and Richard for welcoming me and your quick and clear response…

I already tried to change the port, by using the explanation in this item:

So my first post and attachment was already with another port 8445. I have Homecenter unplugged, so I used that port.

I know did undo the actions from that explanation about ports. And I tried from the first response of Stuart.

The response in cmd can be seen in the attachment. No luck contacting the controller.

Any suggestions for a next step?


Cmd file 2.txt (4.06 KB)

Hi Richard,

By the looks of your screen dump your controller is running happily on port 8688.

You should be able to get the sync page by using

Well indeed. Thank you for your help.
I used local controller instead of

Now, I logged in the local controller and did an online update of openremote designer and the local controller
I can make contact from my smartphone to the network. And I see the buttons.

But when I touch a button, I can see that i press the button, but nothing happens. No actionline is visible on the Golfy server indicator on either side.
I did made a new device, a new command. With specficitions in the attachment picture.
And with that I made a button with that command

Another thing I would mention is that cmd still gives the following error.
INFO 2017-01-20 17:03:33,640 : Unable to retrieve controller identity, retrying
in 1.000 milliseconds…
See the other attachment. Is this right, or the problem?

Any suggestions are welcome.
Thank you

CMD file3.txt (15.5 KB)



Sounds like you're making progress..

The "unable to connect" issue is something to do with the Controller connecting to the online beehive, it's nothing to worry about and won't affect your experience.
Search this group or the old forum for solutions.

Now, one observation about your Velbus connection is this...

Firstly, do you have a good (solid) reason for changing the default port of OpenRemote away from 8688?

And secondly, why do you choose ports that are in use by other software?

Port 8090 (and 8091) are the default ports for PB_Server, so I'll assume that OpenRemote must have started before PB_Server for it to take hold of port 8090?

Unless, you've also changed the default port of PB_Server too?

In which case, have you edited the Velbus connection details within the online designer?

(Then resync the controller to adopt the changes)

Please let us know how you get on.




Oh and one small detail that might help you find problems...

Please take a look in..


You'll find plenty of folders and files in there with all kinds of information.

The ../logs/velbus/velbus.log file will show you if your getting a connection to PB_Server and if modules are initialised correctly.

On that subject, have you got the latest Velbus.jar file (V 1.2.2) ?
This added VMBDMI-R support.

There is another version on its way which will give support for the new VMBMETEO.

Hi Stuart and others

Thank you for your reaction. I will answer the questions

I have no reason to change to another port other than I wanted to try some possible solutions before bothering you in the forum. I thought it would help it use the Homecenter port, but it clear that it isn't.
I have no clue about 8090 and 8091 and how that happen.

I only had changed the discovery config in OR designer, port in server file on the pc , as explained in
But I have changed everything back 8688 as you described.

I have used 1.2.2 jar file

The log file from now is added

So, I m not very helpful I think. If I can give any other information, just say what I can do


log file

velbus.log (47.1 KB)


Thanks for the answers.

So everything should be back in order.

Now, according to your log file, it looks like your simply missing a connection to PB_Server.

This line is the key

"WARN 2017-01-20 16:38:21,843 (Velbus): Connection timed out: connect"

I'd double check that your settings are correct in the online designer.


Port should be whatever PB_Server is listening on, which is shown on the bottom status bar of PB_Server.

Please let me know the results so that I can help you get to the next stage.

Good luck.



Thank you.

Right on the spot. Somewhere down the line I had given PB server another port than Openremote.

When i press a button now, it works. Superb! Thank you for all your help.

Now I am going try to do more. I am going to look how far I can go.


Hello Richard.

I'm very happy that you're up and running.

If you're looking to see how far you can go, you had better prepare for a very long journey :slight_smile:

The combination of OpenRemote and Velbus will give you far more options than you could wish for.

When you get any ideas that you're not sure how to realise, just create a thread on here or the Velbus forum :slight_smile:

Bon voyage :slight_smile:



Hi Richard,

I've just realised where I've seen your name before.....

Thank you for staying with us :slight_smile:



HI Stuart and others

Indeed, that is correct. Know found the time and the urgency to start building openremote.

I got know some thins working.

One thing that worked is to GET information via an api of wunderground via HTTP.

I get the right data on my pc

But somehow it starts the HTTP action about every minute.

feb 01, 2017 6:22:37 PM org.restlet.engine.connector.HttpClientHelper start
INFO: Starting the internal HTTP client

It does not make a diffence how many HTTP commands I make, how often i set the timer for that command, or even if there is a HTTP command. It Always does this.

So Wunderground gets too many requests from me.

I cant figure out a solution. The command file and Velbus log file is attached.

Any ideas?

And another question. Now I use an old windows xp laptop. I would like to use a smaller item to use a service.

Can you recommend a device for Velbus and Openremote? Easy to use for this set up (and furthermore costs, energy and so on)

Thank you


velbus.log (1.51 KB)

Nieuw - Tekstdocument.txt (178 KB)

Good morning Richard,

It looks like you’ve made some progress.

There also seems to be a couple of issues now, of which I am only really qualified to help with the Velbus one.

Have you seen this post?!searchin/openremotecommunity/controller$20identity/openremotecommunity/DtDRX-0N8ec

The best I can do with the others is guess, so I would suggest you search the group for other similar questions, as I’m sure the answers you need are out there.

So to address the Velbus question…

Let’s break down that log file :-

INFO 2017-01-31 18:04:32,515 (Velbus): Device is not reachable so not adding sensor - This means that the addressed module has not responded.
INFO 2017-01-31 18:06:12,250 (Velbus): Device is not reachable so not adding sensor
INFO 2017-01-31 18:13:31,171 (Velbus): Device is not reachable so not adding sensor
INFO 2017-01-31 18:22:59,281 (Velbus): Device is not reachable so not adding sensor
INFO 2017-01-31 18:26:16,812 (Velbus): TCP socket read error - I'm not certain, but I think this means that there was an issue between the OpenRemote controller and the Velbus TCP server (PB_Server in your case)
INFO 2017-01-31 18:27:04,578 (Velbus): Scheduled bus connection task - This is a normal attempt to locate a particular module
INFO 2017-01-31 18:27:11,093 (Velbus): Connection initialised - The above module was contacted
INFO 2017-01-31 18:27:11,093 (Velbus): Stopping connection timer - The time-out timer for the above activity has been cancelled (becuase the task was a success)
INFO 2017-01-31 18:29:14,421 (Velbus): Scheduled bus connection task
INFO 2017-01-31 18:29:20,687 (Velbus): Connection initialised
INFO 2017-01-31 18:29:20,734 (Velbus): Stopping connection timer
INFO 2017-01-31 18:32:03,390 (Velbus): Scheduled bus connection task
INFO 2017-01-31 18:32:09,656 (Velbus): Connection initialised
INFO 2017-01-31 18:32:09,656 (Velbus): Stopping connection timer
INFO 2017-02-01 18:21:41,539 (Velbus): Scheduled bus connection task
INFO 2017-02-01 18:21:48,617 (Velbus): Connection initialised
INFO 2017-02-01 18:21:48,617 (Velbus): Stopping connection timer
ERROR 2017-02-01 18:24:21,305 (Velbus): Device '22' failed to initialise - There was a problem contacting or initialising your Velbus module with the bass address 22 - What is this module? Is it a non-compatible module?
INFO 2017-02-01 19:32:27,883 (Velbus): Scheduled bus connection task
INFO 2017-02-01 19:32:34,351 (Velbus): Connection initialised
INFO 2017-02-01 19:32:34,351 (Velbus): Stopping connection timer
ERROR 2017-02-01 19:35:46,008 (Velbus): Device '22' failed to initialise - There is a clever re-attempt process built into the Velbus protocol so that if a TCP connection fails to a Velbus network, a re-connection attempt is made a number of time is quick succession, then drops to reattempting once an hour.

So to conclude, your Velbus log looks good, other than you have an issue with your module at address 22.

Can you confirm that you are using the Decimal address for this module and what type of module this is.

(Please keep in mind that only the 2nd generation of Velbus modules are compatible with OpenRemote, please review the table in the How-To document - [GitHub - Velbus Wiki](

The only other part of your question I can offer a little help with is about alternative platforms to run OpenRemote on.
My personal preference is the BeagleBone Black, which I sell pre-installed with OpenRemote Pro 2.5.0 and Velbus TCP server, all in a Din Rail (or wall mount) case for roughly 150 Euro including VAT and P&P within the UK.
There is more information about this on this thread - [Google Group - Din Rail controller](!topic/openremotecommunity/wJ5YHx6Q2Rw)

I am playing with the ODroid platform too, as that is an 1Ghz 8 core SBC device, however I'm not finding it that much faster than the 1Ghz single core BeagleBone.

I hope this give you some useful guidance.



Hi Stuart and others,

Thank you for your answer. I wanted to wait for another problem, but that can wait now. It would be nice from to answer.

I do not have the HTTP problem anymore. Also the endless statements are gone, but once in about 15 minutes I do get a messages. But it does not seems to make problems.

Unfortunately, I do not know exactly what was the solution. I did some back and forward of some actions, but I am not sure. I think it got something to do with plain password and just copy a fresh set of document in the ORC folder.

The device and sensor that is not responding is an VMB1TS thermometer. In the previous Velbus version it did not work. I tried the 1.3.0 version somewhere in the above mentioned chaos, but I got a whole lot of errors. Like it didnt recognize the velbus hardware anymore. So for now I put the older version back. I’ll try again later. (it does not help that it is a very slow windows xp laptop)

Thank you about the information of Beaglebone. I never heard of this (or other ones) Although I hear a lot about Raspberry

But it seems fare. Does it come with some how to’s ( how to connect from another pc, how to re install youself)

And, just to be sure, what are the cost with transport and tax? costs for the Netherlands?

Thank you


Hello Richard,

On the whole, it sounds like your moved forward.

The VMB1TS modules will work with the velbus.1.3.0.jar file, so I suspect you lost a setting when you dropped a new set of OpenRemote Controller files in.

It is worth digging a bit deeper to get it all working, which I'm happy to help with.

If you have a working (if a little slow) controller now, may I suggest that you (only) drop in the new Velbus Jar file (and remove the old one) and restart your controller to get access to your VMB1TS modules.

Then reports back so I / we can help you further.

That said, a faster machine (or maybe slimmer OS like Ubuntu 16 LTE headless server) will always make life easier.

For reference, I'm happy to cover postage to NL and VAT in the €150 price of the BeagleBone.

I hope that helps.



HI Stuart and others

Thank you for the info. I ll get back to you on that.

To get a bit further it would help to have some more examples of the rules. I have got the Smart home book and got one example from openremote about warming and cooling

But I cant seem to find a list of examples of what to do with rules. It would help me to find out small stesp myself, without have to post everything.

For example, now I would like to calculate a number from the difference of the outside and inside temperature to change a 1-10 volt thing. And the documentatin about Drools is for now a bit too complex for me.

If there arent any examples of rules. Are some people willing to post their rules in one place or here in the forum?

Because no in the forum there are only some examples, and their posted there because they did not work.