Users page empty after creating new User

I tried to add a new Service User, but after adding the User the Page remains empty. I tried several times with a new Realm, but each time I try to add a new User the Page remains empty.


I assume you are using the default keycloak identity provider.

Just tried this on our daily staging environment and it works ok; there was a related bug a few builds back, are you sure you have the latest docker images.

Hi Rich,

thanks for your Answer. I have Version 2.4 of the Docker-compose file. Everything seems to be fine, until I try to add a user.

Hi Stefan,

to check image version please run docker images "openremote/*"

Hi Michael,

here is the result.


Indeed your manager image is old (we are moving fast :wink: ). Please do

docker pull openremote/manager
docker-compose up -d

Here is my output:

REPOSITORY           TAG       IMAGE ID       CREATED        SIZE
openremote/manager   latest    2f6fe2abb6e2   18 hours ago   425MB

Thank you so much. That solved the proplem (almost). It still happens if I add a user to the Master Realm. After creating a new Realm, I can add Service Users as it should be. Thats fine for me - Thanks again :wink:

Great to hear! I’ve tried adding a new user myself and noticed some glitches too. I’ve filed a git issue for them. If you have other issues you can comment there too. Regarding your blank screen - can you look at your browser JavaScript console?

Tip: if you want to keep your docker image up-to-date with the minimum effort you can use watchtower for it. This way as soon as a new image is pushed to the registry, which is build for every github push in the master branch, your local image will be updated. To run watchtower you can use the following docker-compose.yml

version: '3.2'


    restart: always
    container_name: watchtower
      - /var/run/docker.sock:/var/run/docker.sock
      - /etc/timezone:/etc/timezone
    command: --interval 300 --cleanup --remove-volumes --rolling-restart

The only caveat is that sometimes updating manager image requires whipping the database. If you mind doing this, it is better that you don’t use the watchtower.

Hi Michal,

thanks a lot for your time :wink:

The Javascript console shows an error, if I open the blank User screen. I will keep an eye on it, and wait for updates.

I’ve installed Openremote with Docker. EVerything works fine but if i make a new “service user” the page remains blank after saving the user. How can i resolve this? I tried comment above, but the version i’m running is the newest version. Can anyone help?

Perhaps this is a new bug introduced? For now you can try to checkout the older version and build the image when it was working correctly. Otherwise @Rich is the best person to ask for help.

BTW, this thread is pretty old. It would be better if you open a new one as this seems to be a new issue which is just similar to the old one :wink:

Hi Michal,

I will open a new topic.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.