Access using Nginx proxy manager

Hi all, I wonder if anyone has had the same issues. I can access the local machine using the local IP of the OpenRemote. However, when I use the Nginx Proxy Manager, I receive a 502 Bad Gateway error. I have no idea why this is happening, despite having tried several solutions with no success

While I am not really aware of how it works, OpenRemote also deploys a proxy server, based on haproxy, that manages all of the routing between different services. The ports that are being used can be viewed in docker, by running the docker ps command in a terminal (or looking at your docker desktop containers).

I am guessing that the proxy manager does some funny routing to the openremote proxy, and that would cause some issues. I would first check that the requests actually hit the haproxy instance. You should see something like this pop up in the proxy container logs when you try to access OpenRemote:

http <NOSRV> 0/-1/-1/-1/0 "GET / HTTP/1.1" 302 1/1/0/0/0 0/0

Best of luck!

Thank you for the prompt response, I understand now! I am trying to map DDNS to the service and I am using NIGNX. I tried to use the docker compose to update the domain name, however it keeps pointing back to NGINX as it is the overall reverse proxy. So in summary I want to use the DDNS name with openremote.
Thank you !

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.