Assets receiving 0s from MQTT Agent

Hello all,

I’m having some issue receiving data from MQTT. These are the steps I have taken so far:

  • Set up MQTT Agent
  • Create Assets with Agent Link
  • Create JSON path to filter value

MQTT Agent Configuration

Asset Configuration

However, when the assets receive the data values, it is 0.

I know that the MQTT agent is working and I am also receiving normally because without the filter, I am able to receive the entire JSON message.

Any guidance on this issue will help a lot. Thank you in advance.

Hello all,
I have made some progress but I am met with some different issues.
Things that have changed:

  • JSON Path has been changed and value can be filtered but only if attribute is text
  • Asset can receive data if value is manually sent from MQTT Box
  • MQTT Box can receive from our software that sends out data


Asset receiving from MQTT Box

MQTT receiving data

The intended outcome is for our software to send data over to OpenRemote through MQTT.
However, the data cannot only be received by MQTT Box and not directly to OpenRemote. It was successful before, and all the settings are the same, hence I am lost now. I hope that someone will be able to guide me on this issue, thank you in advance for your help and patience.

Hi all,

The issue with receiving data from our software was solved. Turns out we used the same client ID for MQTT box and OpenRemote, hence only MQTT box was receiving the data. The problem is solved now, although the issue with the 0s is still unknown to me. Hopefully this will be useful for someone. Thank you.

1 Like