Attribute type error

When I try to create a new attribute with a complex type such as temperature, sound and many others, I get a “Missing attribute Type” error when I try to save the asset. I have got the same error when I tried to fulfill the “get started : connect your data” Guide, is there any solution for this ?


There was a bug in the manager which should now be resolved please pull latest openremote/manager image.

FYI: We are in the process of creating a new manager UI but it is not ready to replace the old one so sometimes the old one isn’t kept up to date with code changes.

Thank you for your reply, however the problem still not solved for me, I have pulled the latest manager image and tried to create a new attribute of type “temperature in Celsius” but i still get the same error


I have tried with the latest image from Docker Hub and things work ok for me so please make sure you pull the latest image and also prune docker volumes (that’s probably where you’re going wrong):

docker-compose pull manager deployment

docker-compose down

docker volume prune (assuming you don’t have other volumes you don’t want to lose - otherwise use docker volume rm)

docker-compose up -d --no-build

thank you for your reply, now it worked for me too.

This is a test message