Blank page after custom deployment

Hello guys,

I am having a problem trying to get custom deployment to work on a separate machine. I got everything to work without errors using the wiki, but when i go to http://local-ip-address-of-machine:9000/manager/ i get a blank page. I do see a openremote favicon and the tab is called OpenRemote Demo, so the connection with the server is not the problem.

There aren’t any error messages in the browser console or the OpenRemote terminal. I’ve tried accessing it from different browsers as well.

Is there a problem with running it on a seperate machine instead of localhost?

Thanks in advance!

I’d start off with figuring out if there are any errors on the client, aka the console of the browser. This may have multiple root causes, like the manager not communicating properly with the frontend app.

I’d also take a look at the docker containers, to check if the HTTP requests are reaching the manager container, and also trying to request something from the API itself, to see if the manager is working properly.

Best of luck!

Thanks for your reply,

As i mentioned, there are no errors in the browser console. I do not see any http requests incoming in both keycloak or postgresql. Should there be a manager container running when doing custom deployment?

I just tried setting the OR_HOSTNAME environment variable to my machines local ip address, but this did not work either.

You need to look at the network tab in the developers tool window to see what request is failing and this will provide a clue as to what the issue is.

Could be configuration issue or maybe your OS firewall settings.

It looks like localhost:8080 is failing. Is this keycloak?

The dev-testing.yml docker compose file contains
ports: - "8081:8080"

So it looks like keycloak is running on port 8081. I changed the port of keycloak to 8080, but it did not work.

My OS firewall settings are not restrictive btw.

After a lot of tinkering I now got this. It looks like http://local-ip-address-of-machine:9000/manager/ redirects me to http://localhost:8080/auth. The problem is that the server is redirecting to localhost:8080/auth for authentication, which obviously won’t work when accessed from another computer. If i understand correctly it should redirect to http://local-ip-address-of-machine:8080/auth instead.

How can i make sure it redirects to the correct auth page (i.e. local-ip-address-of-machine:8080/auth) instead of localhost?

Is there no solution for running a custom development on a remote server?

I have had this issue, i changed those settings in the compose yml and it works: (IP ADDRESS = host of OR)

  1. Change “DOMAINNAME: [IP ADDRESS]” in the “Proxy” section
  2. Change “KC_HOSTNAME: [IP ADDRESS]” in the “Keycloak” section
  3. Change “OR_HOSTNAME: [IP ADDRESS]” in the “Manager” section

I know that is the case when you deploy using the quickstart docker-compose (this should be added to the wiki). Better yet, you should set the OR_HOSTNAME environment variable to your server’s ip.

But as i said i am not using the docker-compose. I am doing a custom deployment following the user guide. Thus the manager is not running in docker, but native.

OK, the same variables are in deploy.yaml they point to localhost, not sure if you tried this,

good luck

Thanks for your reply, but i already tried this. I changed OR_HOSTNAME env variable to my machines ip and this should overwrite the values in the deploy.yml.

I seem to face the same issue.
I started with the docker-compose.yml from the quickstart guide.

I removed the proxy, as I’m running another one for my lab.
Proxying 443 to manager:8080 and 443/auth to keycloak:8080.

The issue seems to be that even if you set OR_HOSTNAME, KC_HOSTNAME and the ports correctly the manager tries to reach “https://localhost/auth/js/keycloak.min.js” which obviously fails when the browser is not running on the server.

1 Like