Blank Screen when setting up custom deployment

Hi guys!
I runned the npm run serve command.
However, when I try to access the URL I just have a blank screen:
The log of my inspector window is:

Could I get some help to fix this issue? I followed the step by step of User Guide: Custom deployment · openremote/openremote Wiki · GitHub

The npm command:

Hi,

Not an error I’ve ever encountered, a web search doesn’t indicate a specific cause.

If you try and open one of those scripts in a separate window do you see the JS content or something else?

I was having a problem with the gradlew too. I needed to chmod +x the script of the main project (the custom project). The project has another script that need it?

Just these two messages:
Cannot GET /modules/@webcomponents/webcomponentsjs/custom-elements-es5-adapter.js
Cannot GET /modules/@webcomponents/webcomponentsjs/webcomponents-loader.js

Rich, hi!
I deleted all the project and did the whole process again. Now I’m having another issue, the project is not compiling:


Could you help me?

Another friend is having the same problem as me, his topic:

Hi Lucas,

Apologies for the delayed response.

Make sure you have first run yarn install from the repo root directory

Hi Rich, no problems!

Now I have another problem! I don’t know if it is my error or of your webserver. It is the first time this has happened! It seems that the server is down or blocking my connections!

It happens after the ./gradlew modelWatch command:

Same here, is a general problem.

The error persists after that! But now I have this tip from the Mozilla docs: X-Content-Type-Options - HTTP | MDN

Jitpack was down for a couple of days and we’ve experienced intermittent issues with it in the past so I’ve now updated the code so we no longer depend on it.

2 Likes

I’ve run into the same problem with blank screen and the problem with MIME types. What worked for me after few hours of fight was using ‘/’ at the end of url:

localhost:9000/manager/

Maybe it will fix it also for you.

2 Likes

It worked! But now I’m facing a CORS problem, do you know any solution for it?