Cannot access OpenRemote through IP

Hello everyone,

I am having some problem creating a OpenRemote session that is not at https://localhost but rather my IP.
My final goal is that someone from another computer can access the OpenRemote Manager UI.

I have previously managed to create, access, and change some values all in localhost.
I had to use tomasbarthalot way of doing it (MQTT Connection - #13 by tomasbarthalot).

Now, as I explained earlier, I am trying to create a stack that is not localhost but rather my IP. I am trying to use the quick guide steps but I get this error when I do the following cmd line:

“set OR_HOSTNAME=[my IP] && set OR_SSL_PORT=8443 && docker-compose -p openremote up -d”
1 error(s) decoding:

  • error decoding ‘Ports’: Invalid hostPort: 8443

Using tomasbarthalot solution and trying to access the OpenRemote Manager UI by inserting my IP, I get the following error:
Invalid parameter: redirect_uri

On the forum, I have seen that it is advised to use EXTERNAL_URL but that environment does not exist in my composer.yml.

Does anyone know what I am doing wrong? Could it be that the documentation is not up to date?



EXTERNAL_URL is now obsolete.

Can you provide your compose file? Make sure you have KC_HOSTNAME: ${OR_HOSTNAME:-localhost} in the keycloak environment section.

What is the URI on the keycloak login page - feel free to change the IP address if it is a public one

Hi Rich,

Thanks for the quick answer!

Here is my compose file
docker-compose.yml.txt (2.3 KB)

I can see the KC_HOSTNAME in the keycloak environment and it has the specification that you say.

As for the URI on the keycloak login page, where can I find this?

Thanks again,

Just the value in the address bar of your browser when at the keycloak login page :slight_smile:

Hi Rich,

Ooooh ok, my bad :slight_smile:

I have tried to input the IP address in my browser as suggested in the quick guide but unfortunately, it does not load the page (neither if I try to access it using https://localhost).
I am using the bash cmd given in the quick start guide:

OR_HOSTNAME= OR_SSL_PORT=8443 docker-compose -p openremote up -d

I sort of had success accessing the OpenRemote Manager UI using the IP address in the browser when I was starting a stack with the PowerShell cmd:

cmd /C “set KEYCLOAK_FRONTEND_URL= && docker-compose -p openremote up”

(I got this command from this thread MQTT Connection - #13 by tomasbarthalot)

but then I get an error: Invalid parameter: redirect_uri when I input the IP but not when I use https://localhost.

I am a bit confused about why none are working :confused:

KEYCLOAK_FRONTEND_URL is obsolete in latest versions (they cleaned up this whole mechanism).

If the page will not load then that suggests the stack hasn’t started correctly.

Please provide output of:

docker logs openremote-manager-1
docker logs openremote-proxy-1

NOTE: Container names might be different on your system docker ps -a will show you

Sure thing here there are (btw thanks a lot for the help!):

I saved the logs into these notepads files because I thought it would be easier to read rather than copy pasting them directly as text here.

This one is for the manager:
OpenRemote manager logs.txt (34.9 KB)

and this one is for the proxy:
OpenRemote proxy logs.txt (12.3 KB)

Let me know if there is any extra information that I can provide!

Hi ,
use below yml file before that pull and purge old container.
docker-compose.yml .txt (2.3 KB)

Login in with your machine ip that is

let me know if you are getting error.


Hey Apurba,

Thanks for replying and for the yml file!

I have created a new stack with the compose file that you shared but unfortunately, I am still unable to login into the OpenRemote Manager UI when I insert the IP address in the browser. It gives me as if the page didn’t exist and I have tried the following:

and I have created the stack using the bash cmd:
OR_HOSTNAME= OR_SSL_PORT=8443 docker-compose -p openremote up -d

Looks like the stack is running ok (although looking at output of proxy log it suggests you aren’t using the latest image - always worth doing a docker-compose pull occasionally)

Are you sure you don’t have some sort of firewall blocking traffic?
Can you share output of ipconfig command

Do you get a timeout error on those URLs or some server error?

Hey Rich,

Here is the output of my ipconfig:
ipconfig.txt (1.2 KB)

As for when I input the URLs the picture is what I get…

It’s only when I use the cmd:

cmd /C “set KEYCLOAK_FRONTEND_URL= && docker-compose -p openremote up”

that I am actually able to connect to the OpenRemote Manager UI (although having to use the localhost instead of my IP)

Sorry should have spotted this earlier but the problem is likely that you are

There shouldn’t be any difference between using command prompt and git bash apart from the way environment variables can be set…the problem here is that you are not using the same environment variables in both commands.

If you use the following in command prompt (same as command mentioned in the main then I would expect the same result:

cmd /C “set OR_HOSTNAME= && set OR_SSL_PORT=8443 && docker-compose -p openremote up”

Can you provide output of:

docker inspect openremote-proxy-1

And also:


Hello Rich,

Thanks for the answer. If I try to use the command that you suggest I get an error with the port. It gives this:

1 error(s) decoding:

  • error decoding ‘Ports’: Invalid hostPort: 8443

and it does not create any stack.
I have also tried to use different combinations like 8883, 443, and 8 but they all give the same error. However, if I run the command:

cmd /C “set OR_HOSTNAME= &&  docker-compose -p openremote up”

(So without && set OR_SSL_PORT=8443)

Then it runs but the manager is unhealthy (it gets created, it starts running, stops, and then restarts and it goes in the loop like this).

I am adding the proxy logs for when I don’t use OR_SSL_PORT=8443 in the cmd (and have a unhealthy manager)
OpenRemote proxy logs using CMD.txt (11.4 KB)

Let me know if there is anything that I can do, I really appreciate the help.

Sorry for the delay.

This error looks like it is coming from docker/docker compose and probably related to how command prompt maps in the variables. We only use bash emulated shells (even on Windows) so don’t know exact issues with command prompt/powershell.

You could try putting the values straight into the docker-compose.yml and try looking for similar issues on docker forums.