Can't Sync to Controller 2.5 on Raspberry Pi : Error Msg: The path 'file:/../webapps/controller' doesnt exist.

I have an existing, working design in OpenRemote Designer and I only needed to create a new OpenRemote Controller based on a Raspberry Pi 2

I installed Jessie Operating System and upgraded to latest version with apt-get upgrade

oracle-java8-jdk was already the latest version installed

I installed Openremote Controller 2.5 in /opt/openremote

I started the OpenRemote Controller via sudo /opt/openremote/bin/ start

In OpenRemote Designer, I linked to the correct MAC address of the Controller

In my Browser, I connected to the OpenRemote Controller via and got the usual dialog box got to enter my login credentials

However, when I try and sync OpenRemote Designer, I get the following error msg:

     The path 'file:/../webapps/controller' doesnt exist.

Any help?


I've had this one quite a lot.

I think it's to do with write permissions.

If I start OR from rc.local it works perfectly.

If I stop and restart it afterwards from a command line, even using sudo sh start, it has the same error.

Your resource.path is configured as
in your file.

Controller will try to resolve this based on your current working directory when starting up.
So either go to /opt/openremote/bin and do a ./ start (or run), either update your to use absolute path.

I’ve just had the same issue with a new installation on an Ubuntu 16, Odroid C2, when trying to start OpenRemote using a systemD service file.

Thankfully this topic helped me to edit the



file to set the absolute path :slight_smile:

The SystemD method of starting OpenRemote now works perfectly :slight_smile:

If anyone is interested, here is a copy of the text from the service file, from /etc/systemd/system

Please note that I setup a SymLink from /opt/OR-Pro to wherever my OpenRemote 2.x instance is located, but the Absolute path within is that of the OpenRemote 2.x installation

This file is part of systemd.

Hello, excuse my newbieness as this is the first attempt at any type of open source for me. I have this same error The path ‘file:/…/webapps/controller’ doesnt exist. when trying to login and cannot figure out how to get around it. I have linked my Designer to the correct Controller and all.

I am on MacOS

Thank you for any assistance.