Catalina home error on installing controller

Hello,

Yesterday I started to install the Openremote sofware.

Today when I try to run the controller I get a error in the CMD: The CATALINA_ HOME environment variable is not defined coorectly.

Anybody that can help?

I followed al the instructions on the Openremote website but still ...
Also I reinstalled the Java Development Kit (JDK) package and re-downloaded the controller but still same error :frowning:

I also made the variable java home.

kind regards

Hello Roy,

I'm certain one of the many experienced users of OpenRemote will be able to help you here.

It might be totally wrong, or a red herring, but I noticed on your Velbus forum post that you refer to

JAVA HOME

Where the system variable needs to be

JAVA_HOME

It's a minor thing, but......

Good luck,

Stuart

Hello Stuart,

I put the underscore in the variable but I answer with my phone and there is no underscore in my symbols :s

So that is not problem :frowning:

Thanks for the reply
Kind regards
Roy

Okay.

It was just an idea.

Can you provide a copy of the text from your command window so that everyone can see what OpenRemote is outputting.

(Or you can post one of the many log files. ../logs/ )

I'm very curious what's happening.

Hello Stuart,

Attached a picture of the “CATALINA ERROR”.

I tried again to de-install everything and install it again, but still same error when I try to start the controller.

Al the instuctions on the OpenRemote site are very clear and I followed them step by step …

Indeed It looks like a address is missing somewhere from je JAVA KIT.

While I was searching on this error I found something about a tomcat, but no idea what it is.

Thanks for the reply and the help.

I’m I leek in this things but it is fun.

Kind regards

CATALINA ERROR.jpg

Arrrrrrr

Now that's interesting, and again I might be wrong, as I'm not familiar with the nuts and bolts.

However.

Can you try..

CD c:/OpenRemote-Controller/bin

Then run the bat file

openeremote.bat run

(You can use opemremote.bat start when your further down the line)

Please let us know how you getting on.

Hello Stuart,

I just tried what you said.

Still an error occurs but another one: c:/OpenRemote-Controller/bin is not recognized as an internal or external command, operable program or batch file.

Attached I have a picture of: the error in CD, the variable I made, the installed JAVA KIT and the location of the OpenRemote file.

Hopefully I did everything the good way.

I also tried to set the variable to JRE_HOME because the installed JAVA KIT is called like this, but still the same error.

Daily I’m reading things on the web but no solutions :(.

Thanks

Kind regards

Roy

ERROR.jpg

JAVA.jpg

openremote.jpg

variable.jpg

Hi

I'm sure we'll fit to the bottom of this, failing that you'll have to call the big guns in.

Okay, so the mission is to change the working directory to ../bin/

So, use the cd command to do that, "I think" in Windows you need to close the command (?) with a /

So it would become

cd c:/OpenRemote-Controller)bin/

Once your command prompt says your in the bin folder, run the batch file.

openremote.bat run

That should do something new....

Good luck

Hi Stuart,

With the command cd I finally got into the folder.

Normally when you start the controller you shout have something like: “INFO: Server startup in 3159 ms” in cmd.

I got something different, attached again a picture of my cmd.

If it is good or bad, no idea :s, but the controller dos not start up but one step closer :slight_smile:

Any idea what happened?

Thanx

Kind regards

Roy

openremote 1.jpg

Perfect...

The hint is in your screen shot... :slight_smile:

Try the command again, but without the / after run

(The joys of Windows OS)

The cd command needs the /

The variable for the batch file doesn't.

So, you should be up and running now.

Or at least a lot closer

Hi stuart,

10 minutes before your post the server was finally running.

Its verry strange to see it running and running … in the cmd.

So a made a simple app, check it out on phone and it works :slight_smile:

No can the search be started to know how I can integrate this in a VelBus system and how I need to set really a function after a button.

Thanks for the help for so far!!!

Kind regards

Phew

I'm glad it turned out to be something small.
(I would have been lost if it was more serious).

But, Velbus.... That I can help you with :slight_smile:

Just a thought, if you have a VMBMETEO or any VMB1TS modules, you'll need to update the JAR file to the very latest (by which I mean tonight) to velbus.1.3.0.jar

I look forward to seeing your next thread on Velbus :wink:

You say you're going to search for Velbus help with OpenRemote....

Have you read this How-To document?

https://github.com/openremote/Documentation/wiki/Velbus

Hi Stuart,

I have seen that page on hithub but didn’t have the time to read it.

Small question I will have the VMBMETEO, but what exactly is the JAR file?

Kind regards

Roy

Hello Roy,

There are two elements to your post there.....

Dare I tell you that the answer to the first one will also answer the second one ?

Okay, please do read the how to that I've written, it took me many hours to create and has helped a lot of other users to do what they want with the Velbus hardware.

Now the second part, the JAR file is where the magic happens between OpenRemote and Velbus.

Version 1.3.0 contains the information needed to get OpenRemote to talk to the Meteo.

It's all in the how to document :slight_smile:

That said, if you find something that isn't clear in there, or you find it doesn't answer your questions, let me know and I'll update the document.

Good luck,

Stuart