Configuration Gateway DLSO 8

Good morning, I have a dragino gateway DLSO8.

I need know the configuration that i´ll have configurate in my gateway to connect with the server.

Is the first time that i use open remote.

Thank you.

Hello, we find this manual connect you mqtt to connect the client. I have a question for this.

When we create the client subscrition for the subscribeAttribute in my MQTT client, we write in the topic “dragino-1f9740/7RYY26KxldtRNBkC3xq0FU/subscribeAttribute”, dragino-1f9740 is my client id, 7RYY26KxldtRNBkC3xq0FU is the last stretch url of thing agent. Is correct this configuration?

Thank you.

Hi Carlos,

I think the topic for subscribing to the subscribeAttribute of your asset should be: attribute/7RYY26KxldtRNBkC3xq0FU/subscribeAttribute

Don

Hi Don,
I’ve changed these topics, I attach images with my client configuration and my assets.

I dont know that I can have incorrectly configured, in the logs it gives me a connection error, I attach an image of the error.

Thank you.

The port should be 8883 instead of 1883 (which is for localhost).
If that doesn’t get you a step further, we will see if @Michael has some time to take a look.

Hi don, We have used port 8883 and it gives us the same error.

Thank you.

The error is of a WebSocket agent that you created in OpenRemote? I will see if there is a developer available to take a look as I don’t really understand the setup.

You should be able to send and receive data using your MQTT client and the service user (mqttuser). Does your MQTT client give a connection error?

What do you have connected to Dragino? How will you see the data you receive when subscribing to the boolean attribute in OpenRemote?
What is the ‘DATA’ you are sending? Could you just input a number for now?

Hi Don, we will tell you our configuration.
The error is a log in openremote, we configured a asent called Thing and other DLOS8(gateway) with this atributes.


We created a service user in open, mqttuser.

In our gateway, dragino model Dlos8, we configured in lorawan this option to work in mqtt.

In mqtt configuration of the gateway dragino, we configured the secret of serviceuser mqttuser, the topics with the atributes of the assent Thing, the broker address and port and the gateway id “dragino-1f9742”, in the opcion data we don’t know what value to write. I attach image.

In manager interconnect, we configured the next image that i attach. The status is always conecting and the error message, that we atteached, appears in the logs.

We have a sensor node, dragino model LSN50v2-S31, we configured in the gateway.

Because, are there other manufacturers of gateways and sensor nodes that you recommend us to use in open remote?
Thank you.

Hi,

Not been following this thread but looking at your last few screenshots there’s a few problems.

Manager interconnect Hostname should be just the domain name or IP address no schema (i.e. myiot.es) - The interconnect communication happens over websocket automatically and the service user for this communication is handled automatically (using the manager interconnect with edge gateways is explained in the wiki User Guide: Edge Gateway.

Your dragino gateway is not an edge gateway in our terminology; an edge gateway for us is another instance of our OpenRemote Manager.

Your dragino gateway looks like it can act as an MQTT client but what is the structure of the data that it sends to the topics? Our topics expect data to be in specific formats as described in the wiki Connect your MQTT client.

Hi rico,
Which manufacturer would you recommend us to work on open remote?

Thank you.

Hi Don, we need help because we can´t connet this gateway.

We have a dragino gateway and a sensor node with lora in our network, we have see that our gateway have a mqtt client option.

We known´t if the configuration that we use is correct.

We saw this mqtt connect manual and we configured a asset called thing asset with this configuration


after we created a service user mqttuser

In our gateway we configure this service provider

and in the mqtt client this

image

What should change in that configuration? Do we need a certificate?

Thank you.

I’ve been able to send a value to your attribute using the MQTT X client.
What you could try for Publish:
QoS: 1
Topic: attributevalue/5lb1Iboo4Jmz4acRO3deFo/writeAttribute
Data: 20

(note: attributevalue, not attribute for the topic)

Hi don, i change these values.