Controller starts but is not available

Hi People,

I installed OR 2.6.0 beta2 on a new raspberry. The raspberry runs on Raspbian Jessie with Pixel. So I did not do any additional java setup as indicated in the guide.
However when I fire openremote, the process seems to start, but apparently it stops somewhere along the way.

In my shell I see some comments untill the point “server startup in +++ms”.

When I try to access the controller, instead of reaching the page that allows me to sync with the online designer, it tells me the controller is not available. So there must be something running, otherwise i would have a page saying that it can not be reached.
Auto Generated Inline Image 1.png

Also in my android app, I can add the controller and it will show green. Of course when opening it, there is nothing.

Also in the log files there is nothing. there is no boot.log yet. Only the tomcat log has some data but I do not think there is an issue there.

Is this a known error? Could not fin a related topic yet.
Thanks for helping me out!

Nobody who can give me a hint?

It must be something basic that I am missing here.

the steps I’m following are; within folder

cd openremote/Controller-2.6.0_beta2/controller/runtime/apache-tomcat-6.0.18/bin


I just run the startup script

./ run


Tried also with “start” instead of run and with sudo but (as expected) that did not make a difference.

The output is this:

Using CATALINA_BASE: /home/pi/openremote/Controller-2.6.0_beta2/controller/run time/apache-tomcat-6.0.18
Using CATALINA_HOME: /home/pi/openremote/Controller-2.6.0_beta2/controller/run time/apache-tomcat-6.0.18
Using CATALINA_TMPDIR: /home/pi/openremote/Controller-2.6.0_beta2/controller/run time/apache-tomcat-6.0.18/temp
Using JRE_HOME: /usr

---- Logging ----------------------------------------------------------

Console (stdout) threshold [CONTROLLER_CONSOLE_THRESHOLD]: INFO

System logs:

  • Controller startup log [CONTROLLER_STARTUP_LOG_LEVEL]: DEBUG

Just a tiny thought..

Are you using the full address, including port preference to get to your controller?

yes indeed. I does not show on the print screen but that is because it shows only the first part when the cursor is not in de address bar. If it would have been a wrong address I would receive another page I guess (just like any really non-existing page “can not display” or something like that). The fact that the error states that it is some tomcat functionality must mean that I am at least reaching something, right?

I think I need to get to it to start deploying like you can see in good openremote startup log.

Maybe this beta version is not ok?

Thanks for suggesting at least!

btw, the reason for me to upgrade was related to another topic where I wanted to build some more advanced rules (gratefully inspired by you). You suggested me to downgrade my java, but instead I thought it would make more sense to upgrade the whole thing. Need to do that anyway at some point in time. So, that is why I did not feedback yet in the other topic about the solution. - just defending my impoliteness here :slight_smile:

I have been using 2.6 beta and not seen any issue getting to the controller. Can you copy paste your exact URL from you browser?

Problem solved. Downloaded and ran succesfully the beta 3. While doing so I noticed that the zip file i had for beta2 was only 10 mb. Unnoticed, something must have gone wrong downloading it. Awch!

Now the controller is fully available but a new error pops up now about a KNX sensor. Need to investigate further. Keeps me busy:)