Custom-project can't find some GET-requests in browser

Hi OpenRemote Community!

For a couple days I’m trying to install and run the custom-project codebase.
I’m able to build and run everything as described in the Wiki. i.e. backend with Intellij IDEA, KeyCloak and postgresql in Docker and frontend from openremote/ui/app/manager with npm run serve.

I get a login screen and am able to access with admin & secret but I’m missing a lot of the features.

I’m new to the project so excuse me if I’m missing something very obvious.

Here is the network trace of my browser (Firefox).

If any further information is needed, please let me know.

Part 2 of the trace:

What features are you missing. Could you put some screen shots of your dashbords


The network logs show you have unauthenticated access to the manager.
Which means you haven’t been authorized by Keycloak yet.

There is probably an issue in your local setup, where you’re not redirected to keycloak when visiting the Manager UI. Whether it is environment variables, the docker setup you are running, can’t identify.

Feel free to add additional logs (container logs, manager IDE logging, etc)

I’ve seen the issue quite a lot, so I’ll try to find time to look into it soon.
Let us know if you found a solution in the meantime :wink:

Thanks for your quick replies. I’m happy to inform that the custom project is working as expected now.
I cloned the repo again and went through the wiki-steps, and it works :slight_smile:
I thought I must have messed something up with the docker images, so I went back to the old copy I made and tried to make the project run on that version. However, after going through the exact same steps there, I still get another login screen and an incomplete version of the manager.

  • I ran the gradlew modelWatch command, the docker-compose command, the Intellij IDEA run Demo setup and the npm run serve command again, all from the appropriate paths.

Has something changed in the github repo the last 2/3 weeks that might explain this?
If I find an answer myself I’ll post it here, but for now I am happy that I can go on experimenting in the custom project.