Data Export Issue for User

Hello Team.
I am facing to export data for a user which i create from a realm(not master) , now i want to know how i can be able to enable the option for a USER.

@martin.peeters @pcr


What do you mean with “data for a user” ?
And why do you want to export user data in the first place?
Or are you referring to for example the assets of a specific user?

I don’t know whether we have ‘user export’ functionality on the platform
Keycloak however does have quite an extensive user export functionality,
so you could look into that, depending on the data you need.

Actually my concern is that , when i logged in from master , i can see the option "data export ".
But when i try to logged in from another user , then i can’t able to see the option.

pic from master user below

pic from another user (another realm) below

giving full permision to the user also

I believe this is intentional by design.
The data export is, as far as I know, exporting platform-wide data.
So that’s why only the admin user can click on this button.

But maybe this action should become accessible to anyone with read:admin permissions.

Edit: my bad, see posts further ahead

Forwarding this to @Don

Is any update regarding my issue

The data export page is available for all users. If you don’t have access to assets and attribute data, of course you won’t be able to export anything.

Make sure you have the export page enabled in your manager config. You can do that in the UI (appearance page) or directly in the JSON (or don’t mention headers at all and it will show all). e.g.:

  "realms": {
    "default": {
      "appTitle": "ACME IoT",
      "headers": [
        "map", "assets", "rules", "insights", "language", "users", "roles", "export", "account", "logs", "logout"
      "styles": ":host > * {--or-app-color2: #F9F9F9; --or-app-color3: #22211f; --or-app-color4: #1b5630; --or-app-color5: #CCCCCC;}",
      "logo": "/images/logo.png",
      "logoMobile": "/images/logo-mobile.png",
      "favicon": "/images/favicon.png",
      "language": "en"

Note that after changing the manager config you will need a hard reload to see the changes on your non-admin account if that page is already open.


thanks, @Don, it’s fixed now.