Empty page after fresh installation

I have issue with starting of OpenRemote on Oracle Cloud. Completly fresh installation.

I use Ubuntu 20.04 as system. I have installed Docker and used docker-compose to start docker containers. Looking on “docker ps” it looks that all containers are running fine.
I have also allowed ports 80,443, 8883 to go through and that are visible from outside via public IP. During troubleshooting I tested nginx instalation and I was able to see basic webpage on port 80. So it seems to me that firewall is setup correctly. nginx I’ve uninstalled after my test. I don’t want port conflict.

But when I start OpenRemote and try to connect to it I can see only empty page in browser. Not even login page. But it seems that I’m partially able to connect to manager. Because if I open html code of downloaded page OpenRemote text is there. I have same issue when I start it just with " docker-compose -p openremote up" command and try to connect to localhost.

I’ve start docker-compose not in detached mode so I can see logs but there is nothing unusuall. No error. Just info messages. Any idea where to look further to make it working?

Can you reach: https://localhost/auth?

Hello Denis,
If I try in browser outside virtual machine https://publicipaddress and it redirects me to almost empty page https://publicipaddress /manager/. Title of the page is “OpenRemote Demo” so we can somehow access OpenRemote.

If I tried https://publicipaddress/auth like you have suggested I can see " Welcome to Keycloak" page. But if I click for example on Administration Console it ends with empty page.

Same result I’m getting when I try to connect not with public IP address but with localhost from inside Virtual Machine.


I guess there is a problem with the docker-compose.yml

Did you configured the DOMAINNAME right?

DOMAINNAME: publicip

hmm, I have not configured it.
I’m starting it with KEYCLOAK_FRONTEND_URL=https://publicip/auth docker-compose -p openremote up -d

So you are just actually conifguring Keycloak and not the manager.

In the Docker-Compose.yml edit the following lines:

Line 32:




Line 54:


Line 75:


then you can start the stack with:

docker-compose -p openremote up

1 Like

Denis, thanks, thanks a lot. It works like a magic.

Issue is solved.

1 Like