Error when running project in IntelliJ

Following the instructions from Importing a project in an IDE in Developer Guide: Setting up an IDE · openremote/openremote Wiki · GitHub

These are my settings:
[image 1]

After running ./gradlew clean installDist in the terminal of IntelliJ IDEA, it was built successfully.
[image 2]

This are my Run Configurations:
[image 3]

However, when I Run ‘Empty’, I am faced with this error that will go on forever even though it seems to have been built successfully.

Please advise on what steps to take to resolve this issue. Thanks in advance.

[image 1]

[image 2]

[image 3]

And you have docker running and done what is under ‘Run required services’?

docker-compose -p openremote -f profile/dev-testing.yml up --build -d

Hi, thank you for your prompt reply.
After running docker desktop and running docker-compose -p test5 -f profile/dev-proxy.yml up --build -d in the terminal, and the postgresql, proxy, and keycloak were created successfully.

This is my updated run configurations

After running ‘Empty’, the results were
“Webserver ready on
“>>> Runtime container startup complete”

In my docker, the manager is missing while the rest are there (proxy, postgresql, and keycloak). Local host could not be accessed. However, I am not sure how to create the manager. Please assist. Thank you.

The dev-proxy profile is for running the manager in an IDE behind the proxy container and you would use the Empty with Proxy run configuration in that scenario.

What is it you are trying to do exactly?

As @Don mentioned you generally use the dev-testing profile for manager development work in an IDE and then if you want to use the manager UI during development you will need to use the following commands:

cd ui/app/manager
npm run serve

The manager UI can then be accessed at http://localhost:9000/manager/

I’ve tried this npm run serve method in the correct directory, however it’s returning an error within the package.json.

Upon further attempts, I tried running some of the scripts in “serve” manually, which resulted in this:


However, upon trying to access the URL , the result is as shown:

Looks like the gradle modelWatch task failed which is responsible for generating the typescript model definition.

You can run that gradle command directly to get more information about the failure:

gradlew :ui:modelWatch

As someone going through the same error as the person above, I tried this method yet it seemed to not recognize gradlew

Repeated the steps with ./gradlew, but to no avail

Decided to try running the script attached to “modelWatch” which got me this result

Dev-testing command was also confirmed to be running when those steps were attempted

Trying to run ‘Empty’ run configuration would yield errors.

Hi Bingbong,

Could you try running ./gradlew :ui:modelWatch from the openremote directory (and not the manager app directory)?

Hello Don, thank you for the advice.

I ran ./gradlew :ui:modelWatch from the openremote directory and it seems to have built successfully.

Alongside this, I tried running ./gradlew :ui:build and it was also successful. but :ui:serve: will fail.