gmail via openremote rulesstopped working


I am back with a question. I worked throughout the months on my Velbus / Openremote system with a Beaglebone Black.

Al working fine, untill August 14th.

The rules that I used to send mail if a certain sensor changed always worked, and now stopped working on the 14th.

See the code that I used below.

I was wondering if you know the solution how to fix this, and what I can do to further analyse the problem?

What I have.

  • well the rules are below

  • but I did not change them before, on or after the 14th.

  • I did do an syncronization with the server on the 14th

  • But I only added a lot in UI designer and a bit in Building Modeler/Devices

  • I believe I did not change any command or sensors related to the mail rules.

  • And I have 2 seperate Mail rules, and they are both not working

  • Everything else seems to work fine, including the fysical and virtual sensors related to this mail.

  • and the linkage with velbus system, the internet and the power cable seem to work.

  • the gmail did not send the mail

  • In the logs of Boot, Rules en Velbus I don’t see anything different except for this sentence in Boot.log

INFO 2018-08-26 11:17:14,152 : Controller Definition File Watcher for Default Deployer started.

This is said on synchronization since the first syncronization on the 14th.

  • I tried to:

  • use old back up rules, and syncronize againg

  • power on and off on the server

Anybody has an idea?

Or maybe want you need to know more to have a solution?



rule “Aanzetten Mail Deur Open - Keuken zijraam”
Event( source == “051_04_SE_ST_KeukenZijDicht”, value == “released” )
System.out.println(“Aanzetten Mail Deur Open - Keuken zijraam”);

rule “Verzenden Mail KeukenDeur Open”
Switch ( source == “050_0x_ESensor_keukenmail”, value == “on”)
execute.command (“050_0x_EOFF_keukenmail”);
final String username="";
final String password = “password”;
Properties props = new Properties();
Session session = Session.getInstance(props,
new javax.mail.Authenticator() {
protected PasswordAuthentication getPasswordAuthentication() {
return new PasswordAuthentication(username, password);
try {
Message message = new MimeMessage(session);
message.setFrom(new InternetAddress(“”));
message.setSubject(“Zij Keukenraam gaat open”);
message.setText(“Het raam aan de zijkant van de keuken gaat open.”);
System.out.println(“Er gaat een deur open.keuken”);
} catch (MessagingException e) {
throw new RuntimeException(e);

Have you tried other values in
Switch ( source == “050_0x_ESensor_keukenmail”, value == “on”)?

For example “ON”, “pressed”, 1, etc. is the rule sending e-mail triggered?

Hi michal

thank you.
Well that is not problem. It did work with the values before, and i did not change those values.

Do you or anyone else have another suggestion?


Well indeed. I made a mistake. Sometime I changed the values in the sensor. So the output was altered and therefore the values in the formule did not work. Solved