Gradlew installdist build failed

for some reason I had to reformat my pc, but after I reinstalled everything, prepared the environment, and ran the “gradlew installdist” command i got this error :
Could not resolve all files for configuration ‘:manager:compileClasspath’.

Could not find org.geotools:gt-main:19.1.
Searched in the following locations:
Required by:
project :manager
the problem is that these pages are not found and I didn’t find this .jar file nowhere in the internet.
can someone help me resolve this problem please ?
thank you.
P.S : here is the full build scan :

Hey Amine,

Sorry for the delay; it turns out one of our dependencies changed the URL of their package repo, most of us had the packaged cached so had no problems building, thanks for reporting and should now be fixed with latest commit.


Hi Rich,
thank you for your last reply, after I pulled the latest version, the “gradlew clean installdist” command worked.
However after successfully building the project, I’ve tried to run it, as described in the configuration set on the “wiki/set up an IDE”, but I got a new error :
“JUnit not found in ‘Openremote.Manager’”
here is the configuration I set:

I hope that you can help me resolve this too.
Thank you in advance
Best regards