Having difficulties installing OpenRemote Controller in ARM (RaspBerryPi)

Dear Community,

Thanks a lot for reading this.

Just tried to install OpenRemote Controller in my RaspBerry Pi and followed the instructions given here.

Essentially everything goes fine until I reach the test step. I just try to connect to the controller page (http://localhost:8080/controller.) and when the interface for logging appears and I introduce my designer accounta data (username and password) it gives me an error of wrong username/password.

I made a simple test and I logged into the designer web from the RPi and it really works ok… so the username and password are ok and the RaspBerryPi (itself) is properly connected.

The exception given by java looks to be again a wrong username/password. I did really tried 3 or 4 times.

Version of OpenRemove installed is 2.1.1

Not that I'm an expert on the subject...

But, which designer did you sign up for?

Is it the current V2.5.0?


Did you sign up for the now obsolete V2.1?

Designer V2.5.0 will only work with Controller V2.5.0 (or above)

By the fact that your controller can be found on port 8080 tells me you have the old free controller. V2.1

If the above is accurate, please log into the V2.5.0 designer.openremote.com and follow the button link at the top right hand corner to obtain the V2.5.0 controller.

Which will be found on port 8688 once it's installed.

However, if I've leapt to the wrong conclusion, please disregard all of the above.

Good luck,


Ok… that was the issue. The documentation has a link to create a designer account in 2.5.0 and directing you to download the version 2.1.0 and I was not able to notice that.

Sometime 4 eyes principle is really helpful!!!