HTTP Agents seems not working

I created a HTTPAgent linked with Openweathermap (as described in the guide), but it seems not working because although the status of the agent is “CONNECTED”, I believe that it does not do the actual http calls to the service.

I also tried creating a custom attribute with attributeLinks to distribute the temperature, humidity ecc… values to other assets attributes but nothing, no values.

How can I check if the agent performs the calls to the service?

No informations from the logs

I run the docker images version of openremote pulled this morning.

Any help?


any news? Do your agents work?



Apologies for the delay; the Agent Link UI is currently broken due to a dependency issue, I am hoping to get this resolved in the next day or so, you can keep track here:

Solved again :slight_smile: thanks.

hi @Pierre @Rich Why I got the garbage data under the history . I am doing “multiple attribute with one agent link in http agent”.

The attribute data type is JSON so the history panel defaults to showing each key as a column, there are quite a lot of keys so it doesn’t fit, you will need to volume map a manager_config.json file into your manager with an HistoryConfig specified on the AssetViewerConfig.

@Don Probably one to have on the wiki page…

An example is on the wiki here:

I’ve added a line pointing at that part of the config (see asset-viewer > historyConfig). I didn’t add a detailed explanation, so if you are having trouble applying it correctly please ask here.