Integrating OpenRemote to custom Keycloak install

Hi all,

I am trying to integrate OpenRemote to custom Keycloak install. Keycloak is vanilla version 11.0.2, running in docker container.

In Keycloak I added the “openremote” client ID with all “read” and “write” roles.

As OpenRemote manager tries to connect to Keycloak it returns
OAuth server response: 401
Keycloak serer not available, waiting…

Deploying default OpenRemote Keycloak container (with same config in same environment) it has no problems connecting.

Do I have to pay attention to some other setting for Keycloak? Is in OpenRemote Keycloak setup some custom modification to Keycloak code done?


did solved the “keycloak not available,…” problem was with user id which was different in my custom keycloak install.

I solved it with adding another user entity in table openremote.public.user_entity. For user_id I used id from my keycloak instance. then I copied new user_id and changed openremote.public.user_role_mapping and openremote.openremote.user_asset.

With this it integrates fine into my existing keycloak install, but I still get some warnings but they can be sorted out with right security roles.


1 Like