Manager Interconnect: Local network

Howdy community, hope that all are well!

I am new to OR and busy evaluating it to be used with our BLE mesh networks. I am trying to setup a gateway and interconnect to my central manager. I am not too clued up with full stack development, I am actually a firmware engineer so forgive my lack of knowledge.

I have used the quick start deployment on my Linux machine and also on my raspberry pi, everything is running locally on my network.

Now I have seen that to get this working you need a valid CA, but is there no way around this? I just get “CONNECTING” as a status from my PI side. I have made sure that I can ping both ways between my pi and PC, and I can access both OR servers via a browser. The gateway asset was added etc. I want to test this locally and not go through all the hoops of ECS etc.

Is there no way to just disable https or would this not work with interconnect? I see there is a secured checkbox though. If I can get this working I will post a step bly pleb guide here for the rest of the community.

Thanks in advance!

Interconnect should work fine without HTTPS.
I’ve used it locally while developing for OpenRemote, for example connecting to a local instance.

I think @Rich or @Don can help here, as they have more knowledge about this.

Hi Martin, thanks for getting back to me, I appreciate it.

I am using the default docker file in the quick start guide to deploy on my machine and then on an RPI, how would I disabled https from this file?

The interconnect currently uses websockets so you could try exposing the manager web server of central instance (add 8080 port to manager service ports in docker compose)

Then in the interconnect UI on the Pi you can select insecure and enter the port you mapped to in docker compose.

I’m going to add an item to our backlog so that insecure can allow self signed certs as well as encryption is a good thing.

Hi Rich, thank you for your feedback. Yes, I do think it would be a good thing!

Okay so here is what I have done, on my central manager, I have added 8080 to the ports section

  manager:
#    privileged: true
    restart: always
    image: openremote/manager:${MANAGER_VERSION:-latest}
    depends_on:
      keycloak:
        condition: service_healthy
    ports:
      - "127.0.0.1:8405:8405" # Localhost metrics access
      - "8080:8080"

Started OR on my central manager:

OR_HOSTNAME=192.168.0.107 docker compose -p openremote up

Started OR on my RPI

OR_HOSTNAME=192.168.0.112 docker compose -p openremote up

On my central manager, created a gateway asset, on my PI added the interconnect. Still just getting “CONNECTING”, below is a screenshot of my central manager and my RPI: