Manager UI building but not serving components

Going through the Custom Deployment tutorial: User Guide: Custom deployment · openremote/openremote Wiki · GitHub

I was unable to complete the npm run serve command as tsc hadnt been installed, I got around this by installing typescript globally with npm.

Then I had the problem the module orutil could not be resolved.

This issue was solved by running
chmod +x gradlew
and then ./gradlew modelWatch

Which allowed the npm run serve command which outputted this:


however, at localhost:9000/ , I am having this issue


I have also tried ./gradlew build but that did not solve the issue

Thanks in advance for any assistance.


Note the trailing / is required

Thank you. I am now getting this issue however:

My docker container has built from the command:
docker-compose -f profile/dev-testing.yml up --build -d

as such:

In step 3 of the guide:

  1. Set up your IDE. Note that Application run configurations are already prepared when using this template.
    Use docker-compose -f profile\dev-testing.yml up --build -d and run the ‘Custom Deployment’ configuration. You should have two containers running in Docker, and the manager through your IDE."

Do you run the manager using your IDE?

I use neovim as my code editor. I am running the ‘npm serve – --env=…/…/…/…/deployment/manager/app’ script in my terminal. Is there a manager backend I need to be running?

I only have 1 docker container running called profile.

I have gotten it working by using

docker-compose -p openremote -f profile/dev-ui.yml up --build -d

instead of

docker-compose -f profile\dev-testing.yml up --build -d

should the docs be updated or have I missed something?

The difference is that dev-ui runs the manager, while with dev-testing you have to run the manager using the IDE. If you are just working on the UI or a custom app, dev-ui is fine.

Good that you got it to work :slight_smile: If you have any more questions feel free to post them.