MQTT client does not synchronize anymore after restarting the Docker

Hi all,

I succesfully connected OpenRemote with a HiveMQ broker. I created a few assets, and I was able to subscribe to a topic and update an asset’s attribute.

The problem is that after stopping the Docker in the afternoon and running it again the next morning, the attribute’s value was not updated anymore with the value published into the broker.

I checked that the broker was working, that the publisher was also sending packages, and that the value was different.

The problem was fixed by going to the asset, clicking on “modify”, delete manually the current value, and saving the asset. Then, after a few seconds, the value was updated with the latest value published into the broker.

Any idea of the reason of this problem or how could I fix it?

Thanks in advance :slight_smile:

Hi Dani,

I tried to reproduce this, but from here everything is fine.
Maybe you should look into the backlog?
Stop the docker and go with cmd to your folder, where docker-compose.yml is stored
then start the docker with:
docker-compose -p openremote up
then you can see the backend log

1 Like

Hi Denis,

Thanks for the answer. I saw that when I run the docker from the Docker Desktop I have this problem. But when I do it from the terminal, everything seems working good.

I will keep checking this and I will let you know. Thanks a lot! :slight_smile: