MQTTAgentLink stop working

I have created an integration of a LoraWAN node through The Things Networks. The connection is made correctly (either through the standard port 1883 or the secure port 8883, I have tested both).

I have subscribed to a topic and retrieve the information through a JSON filter. So far everything is correct.

The problem is that after several messages received it cuts off and I don’t receive anything else.

Through the logs it doesn’t say anything in particular.

I could look somewhere else to see what’s going on ?

Thanks in advance. Pepe.-

Hi @jcheca I plan on testing this out his week as well. will let you know if I find anything. But form what you mentioned it sounds like a connection issue to TTN.

Thanks for your help. It is very strange, I have set up the same deployment on another server and another infrastructure (different network, etc.) and it has been running for a couple of hours (longer), in the end it stopped again.

I have another application subscribed to the same TTN topic, server, credentials and it does not crash, it is quite stable.

I’m testing a noise sensor node that transmits every minute (I don’t know if it can influence), once it stops, it no longer works (I enable/disable agent, restart docker, restart server) and it still doesn’t work anymore.

If I delete the node I created (asset) and create it again, it starts working again (just in case it serves as a clue).

Thxs again for your help.

Yesterday I connected my Openremote to a Things Network device and have 16 hours of data at 20 minutes. I think your agent may be dropping its connection.

Thank you very much for your dedication. I confirm that I have also been collecting data since October 23 and at the moment I have not had a disconnection again.

On the other hand, I would like to know if changing an asset of this type between different classification structures can influence this communication breakdown. I mean, I have nodes collecting data, within a parent asset corresponding to a given agent, if that node I edit by changing to another type of agent such as city, is it possible that this change could influence the collection of data?

Thanks in advance again. Pepe.-

I would not expect this to stop the attributes links from working but it is worth testing it out.

Everything was going well. Today, after rebooting my server it no longer synchronizes data. Other applications on that same node in TTN continue to collect data. Probably if I define it again it will start collecting data but I have already lost everything I had and I must reconfigure it again. This bothers me a lot because I don’t dare add more nodes.I have no errors on OR and the agents connection is established, but not working.

what exactly do you mean: " already lost everything". are the devices and agents gone ? Do you have a fresh database?

I want to say that I have lost synchronization with the agents defined for TTN, all of them have stopped synchronizing and I no longer receive any messages. I don’t find any errors because the agent is CONNECTED but I don’t receive any data. I have tried creating a new agent with TTN and recovering data from another node, with this new node I DO receive data, but the others have all been “frozen”. As I said, if I delete them and create them again, I have the subscription working again, but I can’t be generating it every time it freezes without knowing why.

This is an image: https://www.uco.es/users/jcheca/example.png

Important note: in the MQTT agent defined for TTN I have enabled the “Resume Session” attribute and the data to be synchronized has started again. :clap:

1 Like

i had the same issue with TTN and it works. Thanks