Newbie: Failed to sync

I am a beginner, for private use at home. I am on ubuntu 17.10, JDK 9 (I’ve tried 8 as well).

I have got as far as creating the Hello World panel, installing and running the controller, and running the mobile (android) app. That app does find the controller (although I’m confused as to whether I should be on port 8688 or 8080 - the former seems to work but the app says the latter is correct).

The next step is to sync the design with the controller. The MAC address is correct, but if I try to add it to the designer web page I get error:

No controller with the given MAC address was found or maybe it’s linked already.
Please start your controller before linking it, make sure it is not linked yet and that it has internet access.

I don’t know if this is because it’s already linked, but it isn’t listed. It is started, and I tried stopping and starting.

If I try to sync I get the following on the controller terminal. It seems to indicate that ssl is missing. This seems most unlikely, but what else can it be?

INFO 2018-04-12 15:58:02,812 : Starting device discovery service…

ERROR 2018-04-12 15:58:31,034 : Synchronizing controller with online account failed : Downloading account configuration failed : Error constructing implementation (algorithm: Default, provider: SunJSSE, class:$DefaultSSLContext)

org.openremote.controller.exception.ConnectionException: Downloading account configuration failed : Error constructing implementation (algorithm: Default, provider: SunJSSE, class:$DefaultSSLContext)

at org.openremote.controller.service.Deployer$BeehiveConnection.downloadZip(

at org.openremote.controller.service.Deployer$BeehiveConnection.access$300(

at org.openremote.controller.service.Deployer.deployFromOnline(

at org.openremote.controller.action.ConfigManageController.syncOnline(

at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(

at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(

at java.base/java.lang.reflect.Method.invoke(

at org.springframework.web.servlet.mvc.multiaction.MultiActionController.invokeNamedMethod(

at org.springframework.web.servlet.mvc.multiaction.MultiActionController.handleRequestInternal(

at org.springframework.web.servlet.mvc.AbstractController.handleRequest(

at org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(

at org.springframework.web.servlet.DispatcherServlet.doDispatch(

at org.springframework.web.servlet.DispatcherServlet.doService(

at org.springframework.web.servlet.FrameworkServlet.processRequest(

at org.springframework.web.servlet.FrameworkServlet.doPost(

at javax.servlet.http.HttpServlet.service(

at javax.servlet.http.HttpServlet.service(

at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(

at org.apache.catalina.core.ApplicationFilterChain.doFilter(


at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(

at org.apache.catalina.core.ApplicationFilterChain.doFilter(

at org.springframework.web.filter.CharacterEncodingFilter.doFilterInternal(

at org.springframework.web.filter.OncePerRequestFilter.doFilter(

at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(

at org.apache.catalina.core.ApplicationFilterChain.doFilter(

at org.apache.catalina.core.StandardWrapperValve.invoke(

at org.apache.catalina.core.StandardContextValve.invoke(

at org.apache.catalina.core.StandardHostValve.invoke(

at org.apache.catalina.valves.ErrorReportValve.invoke(

at org.apache.catalina.core.StandardEngineValve.invoke(

at org.apache.catalina.connector.CoyoteAdapter.service(

at org.apache.coyote.http11.Http11Processor.process(

at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(


at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(

at java.base/java.util.concurrent.ThreadPoolExecutor$

at java.base/

Caused by: Error constructing implementation (algorithm: Default, provider: SunJSSE, class:$DefaultSSLContext)

at java.base/

at java.base/

at java.base/

at java.base/

at java.base/

at java.base/

at java.base/

at java.base/

at java.base/

at java.base/

at java.base/

at java.base/

at java.base/

at org.openremote.controller.service.Deployer$BeehiveConnection.downloadZip(

… 38 more

Sorry. Are my questions so dim that no one can think of a polite enough reply?

Have you searched the forum in case anyone else have asked the same question before?!searchin/openremotecommunity/Fail$20sync/openremotecommunity/LUGfPsiW1hA

In a short answer.

Port 8080 was only ever used by the demo version of OpenRemote.
Port 8688 is the correct one.

Don't worry about registering the MAC I'm the designer, this is only for commercial applications.

As for syncing...

Can you be a little clearer as to what you're doing / asking please?

My area of expertise is strictly limited to supporting Velbus hardware.
Anything else I attempt to help anyone with is purely on a 'best guess' basis.)


The reason I asked about port 8080 is that that is the port the android app says (on the screen)one should use. I assume, therefore, that the app is a bit out of date.

The reason for asking about the MAC is that the instructions say one should, so I tried. Although others seem to have got it to work, it doesn’t on my system. Still, if it doesn’t matter I guess it doesn’t, but I wondered whether that was why the sync did not work.

As to what I’m trying to do, I was trying to create the simplest possible app to test openremote before getting more adventurous. So I started with ‘Hello World’, as per openremote instructions, but could not get it to work because the sync failed. I eventually managed to do an ‘offline’ sync, downloading a zip file, and so got ‘Hello World’ to work (I do have one panel, so I believe the sync should work).

All I am currently attempting is to follow openremote installation instructions. Nothing more.

I did look at github, and found one other had an open issue for the same sync problem as I had (at

Not that it will not work on Ubuntu but from my experience when I started using OpenRemote last year, Ubuntu was finicky with OpenRemote and I quickly gave up.

Easiest is Raspberry pi or a Windows machine to avoid frustration in the beginning. Once you get more comfortable you could try it on Ubuntu again.

That's interesting.

I've got 3 machines running Ubuntu 16 with Java 6 or 8 without any issues at all.

I’ve given up, for now at least. I’ve just found too many things are more difficult than I would have hoped, from sync, to designing for a Android at a different screen size, and needing to design a load of images.