Nodered as a MQTT Client

Trying to get my rpi zero running nodered with mqtt client node to talk to my OR Master mqtt broker but no luck so far.

I’m following the relevant OR tutorial but some part of my setup in the rpi0 NR or OR is just not habbening. :frowning:

I am getting a ‘connecting’ in the rpi0 NR mqtt node but no ‘connected’ as yet.

Long shot … has anybody tried this and got it working?

If yes … can you poast setup config. please. :slight_smile:

cheers

ps. got the OR weather tutorial up and running … openremote has awesome potential … kudos to the team.

1 Like

Hi and welcome,

I don’t have any experience with MQTT client of nodered but the important things to pay attention to are:

  • enable TLS (not sure how node red validates the certificate chain?)
  • port is 8883
  • provide a client ID (some unique identifier to identify your MQTT client)
  • provide a username (realm:<SERVICE_USER_CLIENT_ID>)
  • provider a password (<SERVICE_USER_SECRET>)

You can always look at the docker logs of manager container for any potential clues…might need to provide a custom logging.properties if you don’t see anything of interest by default.

Hope this helps,

Hi Rich and thx for prompt reply.

OK … totally out of my depth now … never used 8883 port for NR on previous iot platforms … only 1883 …

the following is the server (broker) setup in NR where it asks for certs, etc for TLS config …


any idea which would be the ‘best’ choice or the OR info to input?

cheers

Hi,

This is a question for node red forums.

Your config looks sensible; if you have OpenRemote generating domain SSL certificates then nodered should be able to verify server certificate using standard CA root certificates.

Maybe unchecking the Verify server certificate option will just allow nodered to accept the OpenRemote certificate to prove things are working?