Not all asset types / agents / protocols visible

When I add a new asset, not all asset types / agents / protocols are visible for selection in the Add Asset Form.
I.e. I am missing GroupAsset and I can only see the SimulatorAgent as well as the HttpClientAgent, no other agents.
What do I have to do to enable these missing types?

Thanks,
Alex

Hi Alex,
We had/have disabled a few in the UI as you can’t configure them yet. If you now re-install all generic agents are already visible. The group asset will follow once we have the UI updated (it needs selecting the asset type in the modal, again an update…)

Hi Alex,

You can also enable the asset types you want to see by modifying the manager_config.json in the deployment directory. I will be adding information to the wiki on the options you have in that config later. For now an example on how to edit the excludes in the manager config:

{
  "pages": {
    "rules": {
      "rules": {
        "descriptors": {
          "all": {
            "excludeAssets": [
                "PeopleCounterAsset",
                "PresenceSensorAsset"
            ]
          }
        }
      }
    },
    "assets": {
      "tree": {
        "add": {
          "typesParent": {
            "default": {
              "exclude": [
                "PeopleCounterAsset",
                "PresenceSensorAsset",
                "VelbusSerialAgent"
              ]
            }
          }
        }
      }
	}
  },
  "realms": {
    "default": {
      "appTitle": "Name"
    }
  }
}

Note that this will overwrite the current exclude config, so you will see some asset/agent types that are not fully tested.
It might be more sensible for you to use include instead of exclude so that you only see the asset types you are using in you project.

Don

Hi Don,

Is there any documentation for the manager_config.json file available options? because i need to add a custom asset type to the add new asset page

Thanks

Ahmed

Hi Ahmed,

At this time the documentation on the manager config is limited to this wiki page.
When using the example config I pasted above, newly created asset types will show up automatically in the Add asset dialog on the Assets page (because we use the exclude option in the config). You can not create new asset types using the config, to do that you need to create them in the directory containing asset types. You can use the other asset types as examples.

Let us know if you get stuck,

Don

Hi Don,

Thanks for your support.

I did what you mentioned and create a new Java file cloned from ShipAsset and change its name and build the project and build the manager Docker image but when I tried to add a new asset it didn’t appear in the assets list.

Thanks

Let’s start the troubleshooting by looking at your asset type file, could you post it? I’ll ask one of the developers to join the discussion after that.

Thanks Don

I successfully managed to create a new custom asset, but i have another problem updating the location of this asset from a HTTP POST Request, i checked the wiki pages for HTTP Asset API and it only show examples for weather api. but i want to do is updating the asset location from HTTP POST request rather than connecting to an api.

Thanks