Not Webconsole on Controller 2.6.0 (Beta 2) Qnap TS-239ProII+.

I installed the package OR OpenRemote_2.1.0.0617_x86.qpkg with a Java8 (from qnap app centre) on the Qnap TS-239ProII+ with QTS 4.2.4.
Then I updated the all folders in directory OpenRemote on a new folders from Controller 2.6.0 version.

When I to sync with online Designer - http://192.168.1.9:8088/controller/ ( i change port with 8688 to 8088), I get the working controller, with working Z-Wave and rules, and mail send (javaxmail). Also working Android app 2.3.0 on my smartphone.

But not work Webconsole. At the link: http://192.168.1.9:8088/webconsole/ i am see white page.

How to fix it?

This is a working design that worked for Synology NAS, and Webconsole working well on him.

I am seeing the same issue with 2.6

You have to change Webconsole port to 8688 as well

Hi.

Where can I change the port for the Web Console?

For the Controller, I changed the port from 8688 to 8088 in the file:

/share/MD0_DATA/.qpkg/OpenRemote/OpenRemote/conf/server.xml

``

The controller opens on port 8088.

And Android app also work.

For Webconsol I tried:

http://192.168.1.9:8088/webconsole/

``

and

http://192.168.1.9:8688/webconsole/

``

it does not open - a white page.

change_port.png

Hi

Just a thought.

So you have webconsole.war in this folder ?
share/MD0_DATA/.qpkg/OpenRemote/OpenRemote/webapps/

Cheers,
Stuart

Hi.

Yes, of course there is.

webconsole_dir.png

Just asking :wink:

I had a couple of instances where it wasn't present.

OK, try then renaming it to webconsole.war or call http://controller_ip:8688/webconsole-2.1.5/

Hi, Michal.

I just thought of trying this:

http://controller_ip:8088/webconsole-2.1.5/

``

Its work!

How do I fix the time in the logs? I think this is in the java settings? https://groups.google.com/forum/#!topic/openremotecommunity/xxfyBP42-T0

Sorry about that, this was a glitch in the build script for beta 2.
Controller 2.6 Beta 3 has just been released that fixes this issue.

Ok, thanks for a news.