openremote console does not start after power off.


Best wishes for 2019!

I am getting there to finish everything with
openremote, velbus and beaglebone black server in my house. (well, for now, i

But near the finish line, I am getting in some
trouble. And I cannot find the solution. Can you please help me?

About a week ago there was a fuse broken. It had
nothing to do with my smart home system. But the power of the velbus and the
server was down.

That should not be a problem, because the power of
both devices have been of many times.

Afterwards I found out that I cannot access the
controller of the openremote anymore.

I cannot access the controller OR app. I cannot access
the controller to update. The rules for openremote do not work.

What I tested:

  • The logs in openremote do not show anything since
    the fuse broke. Nothing good or bad is logged. Not in boot.log ,
    drools,log and not in velbus.log.
  • If I connect via the velbus software on a separate
    PC via the server to the velbus, that works. It is fully functional, no
  • So, I think velserv program is running perfectly.
  • The velbus system (seperate of openremote) works perfect.
  • I did not change anything to openremote around
    that time or afterwards.
  • I can connect to the server via ssh
  • On my server the programs Velserv and openremote
    are started via the same file on startup. If I list the current processes
    on the server, it shows that that same file is working.
  • I tried to reboot via ssh with reboot , and tried to restart with
    power on and off. I tried to wait
    long (up to 3 days :slight_smile: ) and short. That all did not work
  • I tried to just start openremote on the server.
    That did now work

I am not sure what to do, nor what information I can
give to help.

Can you help me?

Thank you



What do you see when you execute ps ax | grep java on the server? Why is the contest of your startup file?

Kind regards,


Hi Michal

Thank you for your quick response:

when I execute ps ax | grep java on the server, this is the response.

root@ORPro:~# ps ax | grep java
946 ? Sl 11:10 /usr/bin/java -Dcatalina.home=/opt/OpenRemote-Controller -Dcatalina.base=/opt/OpenRemote-Controller -Dtomcat.server.console.log.level=OFF -Dopenremote.controller.startup.log.level=INFO -Dopenremote.controller.console.threshold=OFF -Dopenremote.remote.command.service.uri= -Dopenremote.device.discovery.service.uri= -Dopenremote.sync.service.uri= -Djava.library.path=/opt/OpenRemote-Controller/webapps/controller/WEB-INF/lib/native -Djava.util.logging.config.file=/opt/OpenRemote-Controller/conf/ -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -classpath :/opt/OpenRemote-Controller/bin/tomcat/bootstrap.jar org.apache.catalina.startup.Bootstrap start
14366 pts/0 S+ 0:00 grep --color=auto java

and this is the file that starts it:

in the folder: /etc

this file: rc.local

this content:

*#!/bin/sh -e

Hi Richard,

It seems that the controller is running but somehow it does not communicate with the outside world. To diagnose it further you can go to the /opt/OpenRemote-Controller/bin directory, stop the service ./ stop and run it from the command line ./ run. This way it will dump all output to the terminal and perhaps you can spot what is blocking it?

Kind regards,


Hi Michal

Thank you. The resulting output can be summarized as this:

Jan 08, 2019 5:29:13 PM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /opt/OpenRemote-Controller/webapps/controller/WEB-INF/lib/native
Jan 08, 2019 5:29:14 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8688
Jan 08, 2019 5:29:14 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 3986 ms
Jan 08, 2019 5:29:14 PM org.apache.tomcat.util.digester.Digester fatalError
SEVERE: Parse Fatal Error at line 1 column 1: Premature end of file.
org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 1; Premature end of file.

It says something about missing folder or file called native. There is indeed none on that destination. But in old backups I cannot find such a folder or file either.

When I google that file i find this tread:!searchin/openremotecommunity/native|sort:date/openremotecommunity/KqIhdWJVT6w/TpR0qM-GCQAJ

And, indeed that solution worked.

This file: /openremote/security/users.xml

was empty. And in previous versions it contained this text.

<?xml version='1.0' encoding='utf-8'?>

So, I changed the file. Stopped and started openremote as you explained. And it now it works.

No idea though, how than file was changed originally.

Thanks for the help!