Openremote/proxy:latest in restart mode

HI There. May be someone has seen this but for some reason openremote/proxy:latest keep restarting even on new deployments.


[NOTICE] (1) : haproxy version is 2.7.0-437fd28
proxy_1 | [ALERT] (1) : Binding [/etc/haproxy/haproxy.cfg:34] for frontend http: cannot bind socket (Permission denied) for []
proxy_1 | [ALERT] (1) : Binding [/etc/haproxy/haproxy.cfg:67] for frontend https: cannot bind socket (Permission denied) for []

Is it possible that the ports are already in use?
You can find out with using netstat for example

netstat -ltnp | grep -w ':443' 

no they are not… I think its something to do with Kernal version and Docker version and Haproxy 2.4 plays up … I even tried other ports

I have been struggling with the same issue for over a week. Right now i have managed to do the following mapping for the proxy :

  - "8080:8888"
  - "8884:8889"
  - "8883:8883"

The problem seems to be that the HAPROXY user does not have the appropriate privileges to bind those ports.

After changing the ports i have encountered a multitude of different issues , related to host mapping, and i am still not over it.

In my case installation on a Linux server with specific hostname ( IP address) which has been mapped in docker-compose.yml file

5.4.0-135-generic #152-Ubuntu SMP x86_64 x86_64 x86_64 GNU/Linux

1 Like

I gave up and installed it on ubuntu 20 LTS with newer kernal and latest docker and docker compose. it worked !!

1 Like