OpenRemote publishing to MongoDB Atlas


I’m having trouble trying to connect my OpenRemote to MongoDB Atlas. I am unsure of whether I should be using something like WebSocket Agent or HTTP Agent.


Alongside this, when trying to create a new Thing Asset, I get:

Unsure as to why


Hi, best use the manager APIs: User Guide: Manager APIs · openremote/openremote Wiki · GitHub

Maybe because you created an JSON object with an array, instead of just a JSON object. So in the add attribute dialog, do not check the array checkbox and create it as a ‘plain’ JSON object.

If you want the array. A value like this would work:

    "ta": null,
    "name": "Alex",
    "salary": 50000
    "ta": null,
    "name": "Bart",
    "salary": 80000

I think you can try the HTTP Agent for MongoDB Atlas with their docs:


I’ve managed to include the URL for MongoDB Api as well as the headers according to the API docs,

I seem to get no errors when I run both lines, however once in a while the Request Headers will return a “Send failed”

Inside my thing Asset,
I’m trying to send the body of the data, and it has the same error as the Request Headers where sometimes it runs fine, but no new data shows up in my database. Also, again, once in a while it will show a Send failed.


I don’t see enough detail about your agent link configuration which would explain when the HTTP endpoint is actually called.