OpenRemote V3 on Synology NAS

I’ve managed to run V3 manager (with embedded controller) on my Synology NAS. I have DS1521+ with Intel processor, 3GB RAM and DSM 6.0.
IMHO this is better option than installing OpenRemote through patters package. The image comes with the latest Controller 2.5 from GitHub and embedded open java 8. Anybody wants to test it on a different Synology model? I doubt though that it will run out of the box on an ARM system.

I'd be willing to give it a go if somebody could pass on instructions.
I have a DS415Play and am already using it to run the pro designer controller


Here are the steps (please note that you have only 1GB RAM on your Syno, therefore there can be some swapping)

  1. Install docker package through the Package Center. It can be found in Utilities.

  2. ssh login to your diskstation

  3. curl > docker-compose-synology.yml

  4. sudo docker-compose -f docker-compose-synology.yml up

wait till all loads, this can take a log while as about 1GB of images need to be downloaded.

  1. when you see running containers in Decker UI you can access manager on http://diskstation.local:8080

V2 controller is on http://diskstation.local:8688/controller

Kind regards,


Thanks - I'll try and give it a go over the weekend
what is the function of the V3 manager or where could I read about how it ties into the new overall V3 solution ?

You can read a little bit on, but it is mostly technical. From a user point of view, the manager will replace designer and much more. It should be one stop shop for a complete IoT. There is a map where you can see all your assets (at the moment you can link V2 controller, but in the future you can expect also 3rd party devices, like WeMo, Netatmo, Nest, etc.) There will be also a flow editor, a kind of graphical tool for UI design and rules. A preview window with the mobile app. I’m not the best guy to discuss the roadmap, but these who are are also on this forum. So if you keep asking then they will answer. All this is in a pretty early stage, therefore if you come up with nice idea which should be added to the system, there are chances that it will be. Nevertheless, there is finally something which runs and can be showed, perhaps with hick-ups here and there.

Hi Michal,
Sorry for the delay on this but I was away and only got to try this over the weekend.
Bad news I'm afraid - When I run step 4 (sudo docker-compose -f docker-compose-synology.yml up) it hangs and and the only way to recover is to hard-cycle the NAS. I tried this a couple of times and the same result. I have plenty of space so thats not an issue but maybe the NAS is under-powered.


This step downloads about 1GB from internet. Depending on your internet connection it can take a while. Maybe just let it run until it hopefully finish?

My internet connection is 350 mb so 1 gb data shouldn't be an issue
I left it for 2 hrs yesterday and had to hard-reset the NAS to get it back

I'll give it another go this evening...

Yes, your internet seems good enough. I have less than this. What do you see after issuing the command? You should see downloading action.

Anyway, we are working on the live demo which should be ready in few days. Also, we are building installers for Synology, Raspberry and Beaglebone, which should come shortly too.

I tried that again last night and it hung again.
no error is showing = the NAS just becomes unresponsive

looks like I'll need to wait for the installers

BTW - I re-created my 2.1 project in 2.5 a few weeks ago
Do you know if the designs created in 2.5 will be compatible with v3.0 ?


There are compatible now and I see no reason why they shouldn’t be in the future. But sure you can never be :wink:


This is a very old branch, which wasn’t merged into the main repo.

I’ve attached the docker-compose-synology.yml copy which I’ve found on my Synology. I’m not sure if it will work or whether it is worth to look at it as OR V3 changed a lot since then.

Kind regards,


docker-compose-synology.yml (4.25 KB)