Openremote webui on digitalocean debian droplet not working

steps to reproduce:

  1. create DigitalOcean droplet : 1 GB Memory / 1 Intel vCPU / 25 GB Disk / FRA1 - Debian 11 x64

  2. follow install instructions according to openremote/ at master · openremote/openremote · GitHub

  3. use ‘OR_HOSTNAME=[public ip address] OR_SSL_PORT=8443 docker-compose -p openremote up -d’

as start command.

Multiple issues occur at this point:

  1. COMPOSE_HTTP_TIMEOUT=300 needs to be included in command due to always timing out. This could be digitalocean slow connection I guess…
  2. System reboot is always required after the command, due to container ‘openremote/manager’ getting stuck in infinite restart cycle.
  3. After reboot all containers report healthy, but cpu is at 100%. ‘top’ command tells me some java process is using most of it.
  4. webui is not reachable, only blank page. ‘page is not reachable’. I’ve tried various combinations of ssl/non ssl, ports and /manager or /auth and my external ip address, but it’s definitely not there.

I must be doing something wrong; could it be that the specs of the droplet are too low? If anyone has any suggestions, please let me know!

did you check the minimum system requirements, your instance it quite small

Can’t really find any, but I’ll try with 2 gb mem and 50gb hdd and see if it helps. I’ll report back here.

Please try with at least 4GB to be safe.

Ok, the situation has improved. Current issue is that the ip address sends me to the /manager page, but still displays ‘this page isn’t working’ . One of the containers has these errors:

[NOTICE]   (17) : haproxy version is 2.7.0-437fd28
[ALERT]    (17) : config : parsing [/etc/haproxy/haproxy.cfg:67] : 'bind *:443' in section 'frontend' : unable to stat SSL certificate from file '/etc/haproxy/certs/00-cert' : No such file or directory.
[ALERT]    (17) : config : parsing [/etc/haproxy/haproxy.cfg:81] : 'bind *:8883' in section 'listen' : unable to stat SSL certificate from file '/etc/haproxy/certs/00-cert' : No such file or directory.
[ALERT]    (17) : config : Error(s) found in configuration file : /etc/haproxy/haproxy.cfg
[ALERT]    (17) : config : Fatal errors found in configuration.
[ERROR][2023-02-14 18:47:37] Cannot start proxy until config file errors are resolved in '/etc/haproxy/haproxy.cfg'


I just a beginner with openremote but, I got a similar error when I was trying to configure the android app to connect to my openremote in my local network. I change the file on …\deployment\manager\consoleappconfig, in my case “master.json” to point to my local ip address and port, but i got that error o similar. So I decide to not try the app in my local network for the moment.


For anyone reading this; I solved it by removing the ‘OR_SSL_PORT=8443’ of the startup command. You guys should really consider removing it from the installation instructions!