Paricular attribute notification not coming

Hi Team,
i get mail as “testrule” ,where Particular attribute values are not there .
I configured as below


In this case i only get notification if values are geater than 100, But i got mail below (included all attribute)

So, how I can set notification for particular Attribute.



Apologies for the delay; this behaviour is very strange and suggests a bug but not seen it anywhere else. Will need to try and reproduce this and get back to you.

Okay , Thanks, waiting for update.

Hi @Rich
any update on this, still i got same.


I believe this is by design but I’ll need to look through the code when I get a minute.

Any attributes eligible for use in rules will show in the email allowing easy identification of the state of the asset at the time of triggering.

I’m thinking we should add an option to make this configurable.

@Rich okay, that’s good.
waiting for update, because client need it for particular attribute.
But it was working fine when i configure it first time that is approx 6-7 months ago.


Also noticed the change. Created an issue Rules: all attributes shown in text · Issue #1068 · openremote/openremote · GitHub

This issue should now be resolved with latest docker image

1 Like