Please advise how resolve it

I have follow the Quick started steps as below

  1. Make sure you have Docker Desktop installed (v18+).
  2. Download the docker compose file: OpenRemote Stack (Right click ‘Save link as…’)
  3. In a terminal cd to where you just saved the compose file and then run:docker-compose -p openremote up
    I have got the result as
    [root@FogsCloud ~]# docker-compose -p openremote up
    Creating network “openremote_default” with the default driver
    Creating volume “openremote_temp-data” with default driver
    Pulling postgresql (openremote/postgresql:… Pulling from openremote/postgresql
    a4feded82f54: Pull complete
    d19e7242f4bd: Pull complete
    6cb253df2129: Pull complete
    ea721dc98310: Pull complete
    68f7cd84a8b8: Pull complete
    8393cbb84c4e: Pull complete
    287e8e4b251d: Pull complete
    2122c0a410c8: Pull complete
    ce2fcfb3d94a: Pull complete
    5124a549865d: Pull complete
    57ea93a66d30: Pull complete
    c9462e801511: Pull complete
    b1177777b89f: Pull complete
    bb48c796065e: Pull complete
    fad10c093cb5: Pull complete
    Digest: sha256:0652499c8a168ef8b234358d772ffe3d12fb47b3e625a4dc41bb8e49bd24c0f7
    Status: Downloaded newer image for openremote/postgresql:
    Pulling keycloak (openremote/keycloak:… Pulling from openremote/keycloak
    42f70057e367: Pull complete
    a4360c9d581f: Pull complete
    9500ecdf24fc: Pull complete
    7e40dcd7f910: Pull complete
    9e6297f27708: Pull complete
    447b6d2b318a: Pull complete
    52634d5cbf09: Pull complete
    585c5f20bca2: Pull complete
    c7777310ac9d: Pull complete
    95e2f5eca867: Pull complete
    05c36f1dc3a0: Pull complete
    Digest: sha256:78923e9f97d276c64bb10fcbbf0528f95e62d1e4b27c48c88af4d2315ed20de0
    Status: Downloaded newer image for openremote/keycloak:
    Pulling manager (openremote/manager:latest)…
    latest: Pulling from openremote/manager
    dde93efae2ff: Pull complete
    94249d6f79d2: Pull complete
    f6623006100f: Pull complete
    ac33cb6a1b77: Pull complete
    0f29a97ae338: Pull complete
    5c66c968c1c3: Pull complete
    bca9b83789ed: Pull complete
    d4262c94038e: Pull complete
    29de79415b59: Pull complete
    c4f00392b1e0: Pull complete
    0bf13dfcf693: Pull complete
    8ff71aac6fd4: Pull complete
    Digest: sha256:95713c21ae1813e936c81a16fe018ffc88c2b430bf8921ea4244b9a365f39739
    Status: Downloaded newer image for openremote/manager:latest
    Pulling proxy (openremote/proxy:… Pulling from openremote/proxy
    aed007321795: Pull complete
    f838151fa296: Pull complete
    064cdc3c1f3e: Pull complete
    d19d99e0cdc3: Pull complete
    f653d7732b2e: Pull complete
    145bb878e418: Pull complete
    0ca7df65c0b5: Pull complete
    adb727e5452e: Pull complete
    7499167283b9: Pull complete
    d529544ae7d1: Pull complete
    cc404c6fb5e7: Pull complete
    0f16064242b8: Pull complete
    cdc20acf09c7: Pull complete
    c88a4693f213: Pull complete
    a8f9294c4658: Pull complete
    Digest: sha256:9468b6cc41b49d530901698f5dc0933d24dee7a366192517160080065e605ce7
    Status: Downloaded newer image for openremote/proxy:
    Creating openremote_postgresql_1 … done
    Creating openremote_keycloak_1 … done

ERROR: for manager Container “1bf2362f4406” is unhealthy.
ERROR: Encountered errors while bringing up the project.

However after this I still can’t open the OpenRemote Manager UI page. it is shown as

This site can’t be reached

Please help on how to resolve this problem.

You can try to see status of running containers with docker ps command. If a container is unhealthy you can look at its logs with docker logs openremote_manager_1. This should give you some insights.

Hi, Michal,
Thank you for your advice. the docker ps was shown as

[root@FogsCloud ~]# docker ps
1bf2362f4406 openremote/keycloak: “/opt/jboss/tools/do⦔ 7 hours ago Restarting (1) 41 seconds ago openremote_keycloak_1
14630acb6c76 openremote/postgresql: “docker-entrypoint.s⦔ 7 hours ago Up 7 hours (healthy) 5432/tcp openremote_postgresql_1
67fd406d73b1 docker/getting-started “/docker-entrypoint.⦔ 2 weeks ago Up 2 weeks>80/tcp, :::80->80/tcp festive_sammet

However when I execute docker logs openremote_manager_1, it is show as

[root@FogsCloud ~]# docker logs openremote_manager_1
Error: No such container: openremote_manager_1

So there is no such log file. Please advise on it again. Thanks
I have installed docker compose and Java already.

Ok, I see. You have a problem to start keycloak already. Therefore the logs to check are docker logs openremote_keycloak_1 or simply docker-compose -p openremote logs

Nevertheless, when keycloak is falling to create healthy container this usually indicates on resources problems. What is you RAM size?

Thanks for your advice. I did to execute the command

docker logs openremote_keycloak_1

and it is repeat to give as

User with username ‘admin’ already added to ‘/opt/jboss/keycloak/standalone/configuration/keycloak-add-user.json’

To answer your question for the RAM. I did free command and show as

          total        used        free      shared  buff/cache   available

Mem: 811552 312360 149372 58884 349820 316228

Please advice what I should going to do for resolve the problem. Thanks

I think it is due to the fact that you have already tried to bring up the stack previously and some litter stayed. Please try the following:

docker-compose -p openremote down
docker volume rm openremote_postgresql-data
docker-compose -p openremote up -d

Hi, michal,

when I execute docker volume rm openremote_postgresql-data, it is given as

Error: No such volume: openremote_postgresql-data

so I can’t remove it since it is not exist. I did try to shutdown and up openremote few times. the map of main page is still blank.

Please check volume mappings with docker volume ls. Also you can try docker volume prune command after docker-compose -p openremote down command to remove all volumes.

[root@FogsCloud openremote]# docker volume ls
local 5dc73ddaaad07908c1c37ccf85cc1b9dc52d784bf19b9382f96120f706f2c9b8
local openremote_temp-data

However my main page map is still blank.

Is this the same problem as in the other thread? How to customise the map

yes. it is a same case from me.

Then I’ll close it here as the original problem mentioned in the first post is already solved.