Problem with map customization

Good morning everyone
I have a problem on my test instance. It’s a bit of time since I logged in, and I noticed that after a restart the map is defaulted to Rotterdam as in the beginning.

-already pulled latest image
-if i put my mapsettings.json that worked before

  "options": {
    "default": {
      "center": [ 9.91, 44.92 ], # E,N
      "bounds": [ -34.49296, 29.735139, 46.75348, 81.47299 ],
      "zoom": 14,
      "maxZoom": 19,
      "boxZoom": false,
      "geocodeUrl": ""

I get blank map
-If i remove the mapsettings.json → blank map
-If i just put the default json from GitHub I get Rotterdam but no customization option in the manager, don’t even see “smartcity”,“default” etc.

Any ideas?
Many thanks!



If it worked before, can you check your configuration? The environment variables OR_MAP_SETTINGS_PATH and OR_MAP_TILES_PATH are very likely empty.

If they are empty, openremote takes the default mapdata.mbtiles file and mapsettings.json files provided by the default manager. Which results in going back to Rotterdam.

If you are using a custom-repository, check the docker-compose.yml file you are using. Most host environment variables are copied into the environment of the manager container. This is not the case for OR_MAP_TILES_PATH in the standard provided docker-compose.yml.


Hi Peter, thanks for your answers
Variables are not configured but I have replaced the mapdata.mbtiles with mine and the mapsettings.json with my configuration.

Also one thing I just noticed:
-in the production instance (map working correctly) we started customizing the map from the manager GUI when it was updated, and checking the folder I can only see a “save”

-rw-r--r-- 1 support support 19859M Aug  1  2017 mapdata.mbtiles
-rw------- 1 root    root        1M Nov 14  2022

But the map is correct and customized via GUI, and has no problem on restarts.

The lab instance has the correct mapsettings.json but no possibility to customize via GUI.
If I try to do the same thing an rename the json I just get Rotterdam with the GUI not allowing me to edit the map settings


I am not a developer of openremote. I cannot help you with the exact implementation details of saving settings files. I only can give you advice on the things I experienced as a user.

I have had to add custom geojson features to the map. The GUI to manage the map settings is compelling but is picky to user errors if you change the mapsetting.json manually. One thing I noticed is that the GUI of the map settings disappears if no map setting is available in advance in the mapsettings.json. It looks to me that you suffer from the same or similar issue.

So, the GUI will appear if a correct map setting is available for any realm in the mapsettings.json. You can now add more configurations via the GUI.


Apparently it’s the exact opposite, it disappear when I put the file, but I have it in the other instance where the is no json

Strange thing, because it worked for a while
@Don do you have any idea?