Quick Start Issues

New to openremote and docker. I am trying to follow the quickstart instructions located at

I downloaded the docker-compose.yml
I run docker-compose pull and get this message: level=warning msg=docker-compose.yml: version is obsolete

I run docker-compose -p openremote up and get this message:

manager-1 | at org.openremote.container.security.IdentityService.start(IdentityService.java:62)
manager-1 | at org.openremote.container.Container.start(Container.java:167)
manager-1 | at org.openremote.container.Container.startBackground(Container.java:211)
manager-1 | at org.openremote.manager.Main.main(Main.java:31)
Gracefully stopping… (press Ctrl+C again to force)

Any suggestions?

Hi!

First of all, welcome! :wink:

When running docker-compose up as you did earlier,
it will stop OpenRemote once you close the terminal or exit the process using Ctrl+C.
This is the default behavior of the docker-compose CLI tool.

If you do not want this, and keep it running when exiting, you can run it in “detached” mode;

docker-compose -p openremote up -d

It will now keep OpenRemote running until you run docker-compose down,
or manually stop the docker containers.

Hope this helps! :grin: