Rules aren't being applied

Hi everyone!

I’ve created a set of When - Then rules that trigger when a certain condition is met. Although, there’s a slight issue. Whenever the condition is met when an asset gains a specific value, I don’t see any change in the other asset’s value it’s meant to affect. Anyone that can shed any light on this?

Thanks in advance,

Could you give more details on the rule and the asset attributes (and its configuration items) that are being used? Maybe add some screenshots.



Hello Don,

There’s a Simulator Agent which is used to provide data to the assets. I’ve created 4 Light Assets which include an Agent Link that replays a JSON dataset for a 24h period.

This is the image of the first light asset.

The other asset is a people counter which also makes usage of the same simulator agent.

This is an image of the asset.

This is one of the rules I’ve created, whenever the count total attribute is greater than or equal to 50, the brightness attribute of each light asset should be set to 70. However, that doesn’t seem to be the case as the data still follows the same pattern provided by the Simulator Agent rather than the changes by the rules when each condition is met.

Hmm, I’m not seeing any obvious issues. Maybe the value that is written by the rule gets immediately overwritten again by the simulator agent? You could try turning that off for the lights and see if its written correctly.

If its still not working you could also try writing the countTotal yourself in view mode (so disable read only for this) to see if it triggers in that case.

If still no luck, check if there is something in the logs about that rule.

Hey Don,

Sorry for the delayed response.

I did manage to somehow get it semi-working. I experimented a bit with the configuration items of the brightness attributes and included ‘Rule event’, ‘Rule state’, and ‘Rule reset immediate’ as well as the ‘Update on write’ parameter on the agent link. Now my issue is, that the rules are only working for a single moment and afterward the asset continues receiving data from the Simulator Agent, without the rule taking any effect after. Instead, I have to disable and enable the rules again and for that moment, it works again and that’s pretty much what has to happen each time.

This is what’s in the logs if it helps.