"Saving your design failed due a prior safety lock of your account" How to resolve?

I can’t seem to get anything to save or export as .zip. I get the message “Saving your design failed due a prior safety lock of your account.” How can I get the program running? Thanks!

I’m running the 2.6 beta on Windows 10 and jdk-8u111-windows-x64.exe

Should I downgrade any of the packages?

Can anyone please give me a pointer??? I’d really like to explore this platform but i can’t get it to work at all. Google did not help me with this issue. Thanks!

Try searching for similar issues, you'll find that this question has been answered many times.

Hi, I have the same problem, and have tried to search for a solution, but without seccess. Do you have a link?

lørdag 26. november 2016 07.26.39 UTC+1 skrev Stuart Hanlon følgende:


in the meantime the designer was reset. Please check if you can save your work now?

Kind regards,


Yes, this works now thank you for the update!

Same problem today openremote running on synology

Dear all,
I am using last Pro Designer version 2.5.
I exported the designer into zip file, I edited the panel.xml inside the archive to modify the label of some component, I create a new archive again and when I tryed to import I receive the following message:

“There was an implementation error in Designer while restoring your account data. The system administrators have been notified of this issue. To prevent potential damage to your data, further modifications have been disabled until the admins have cleared the issue. Do not make changes to your designs or configuration during this period, as these changes may get lost. For further assistance, please contact support. (Error Message : Restoring your account data has failed. Please contact an administrator for assistance. Avoid making further changes to your account and design to prevent any potential data corruption issues: No row with the given identifier exists: [org.openremote.modeler.domain.DeviceCommand#754140]; nested exception is org.hibernate.ObjectNotFoundException: No row with the given identifier exists: [org.openremote.modeler.domain.DeviceCommand#754140])”

Even if I pressed Cancel button, and nothing was imported in designer, at the moment each time I try to save I receive the message “Saving your design failed due a prior safety lock of your account. Administrators have been notified of this issue.”

What can I do?

I’ve been having the same error along with issues registering and logging in, It seems to be the site not functioning properly, or the site being down. Any help would be appreciated.

I have just joined OpenRemote and have struck this issue. I can’t save, or authenticate the controller (I get “Authentication failed, please check your username and password”), even thought it is definitely correct (and yes, i know it is case sensitive). What’s weird is that I am also unable to log into the forum to comment, even though my username and password work elsewhere. But I can log into the designer, but can’t save “Saving your design failed due a prior safety lock of your account.”

Will the administrators remove the safety lock?

Thanks for any info in advance.

I’m getting the same message error above and cannot synchronize my controller. When I try to export using the designer I get the message “500 call failed on the server”.

Was anybody able to solve this issue ?

Hi Michal,

Can you reset my designer as well ? I cannot save or import any projects as I always get the error message “Saving your design failed due a prior safety lock of your account”.

My user name is alex.rodrigues


I completely gave up on this platform because nothing worked for me and I couldn’t get any answers to simple questions. Seems like a cool project but the community just isn’t behind it.

I was finally able to make OpenRemote work for
the first time. I’m posting below the issues I found and the steps I did so new
users can understand what to do as not everything is straight forward. I really
recommend using the OpenRemote sample project (Home Example sample file
openrempote.zip located here https://github.com/openremote/Documentation/blob/master/referenceprojects/openremote.zip
from this reference page here https://github.com/openremote/Documentation/wiki/Example-Home
) to make sure everything is working properly. Note that I’m a beginner on this
and am just trying to describe the steps I went through to make things work for
the first time.

  1. Create
    your account by going to this link http://www.openremote.com/professional-designer/
    and clicking on Order Now. For private use, on the order screen click on add
    coupon and insert coupon code PRIVUNIV. You will not need to pay anything for
    private use when inserting this coupon code. You will immediately receive an
    email with the subject “OpenRemote Purchase Receipt”. You will need a second
    email “OpenRemote Designer Account Registration” which contains a link to
    activate your account. It took almost 24 hours for me to receive this email.
    Once you get it click on the link to activate your account. Note that the email
    says that you have a password but it doesn’t say what the password is so after
    clicking on the account activation link I clicked on “Forgot Password” and immediately
    received a new email titled “OpenRemote Password Assistance” with a link to
    create a password. Once the password is created you can now access the

  2. Go to http://www.openremote.com/ and click on login. Use the user name sent to
    you on the “OpenRemote Designer Account Registration” and the password you
    created in step 1.

NOTE: Do not Click on Remember Me on the login
page (I think this feature was removed now). If you do so next time you try to
login you will get an error “There was an implementation error in Designer
while restoring your account data. The system administrators have been notified
of this issue”. If this happens you need to go to your browser settings and
clear the cache, cookies and password for the OpenRemote site. After doing that
you should be able to access OpenRemote again.

  1. After
    Login in, you will be at the Designer page. Click on the Import icon on the top
    left of the page and upload the openremote.zip file (located here: https://github.com/openremote/Documentation/blob/master/referenceprojects/openremote.zip)

If you get the message ”Saving your design failed due a prior safety
lock of your account” it is because your account is locked. You will get the
same message if you try to save your project by clicking on the Save button
(top left). After reading other posts in this forum I realized that the only way to solve that was to reset my account
which only an administrator can do. As a work around I created a new account
and was back to step 1 above. But using my second account solved this issue.
Also, if you don’t want to create another account it looks like locked account
are reset automatically in a daily basis (see https://groups.google.com/forum/?utm_medium=email&utm_source=footer#!searchin/openremotecommunity/cookies%7Csort:relevance/openremotecommunity/y338RXjuYI4/NAQCNHXUBQAJ)

  1. After
    you successfully imported the opneremote.zip file, still in the Designer page click
    on “Download Resources” which will lead you to this link here: https://github.com/openremote/Controller/releases

I downloaded the controller Version 2.6.0 (Beta

  1. (https://github.com/openremote/Controller/releases/download/v2.6.0_beta/OpenRemote_Controller.zip)

Unzip the controller to a local folder in your
PC (example C:\OpenRemote).

You need to have the Java Development Kit and
have the environment variables set as explained here: http://www.openremote.com/install-the-controller/

I’m running Windows 10 so I used the Windows

After having the variables set, go to your
OpenRemote bin folder (C:\OpenRemote\bin) using the DOS Command Prompt and run “openremote.bat
run” command line.

I’ve got the message “INFO 2017-01-25
20:04:17,735 : Unable to retrieve controller identity, retrying in 1,000
milliseconds…” which I don’t know how to solve but it doesn’t look like it
creates a problem, the controller is running anyway’. Let the controller
running on the command prompt.

  1. Got to
    and type in your user name received in your “OpenRemote Designer Account
    Registration” email and the password you created in step 1 above and your controller
    should sync with the project you imported in the designer. If you get the
    message “Authentication failed, please check your username and password.” It is
    because your account is locked. See step 3 above on how to solve it.

  2. Download
    your App. In my case I have a Samsung Galaxy Tab 4 so I used the OpenRemote
    android app from PlayStore. After you download the app and run it, you will get
    the configuration screen. Click on Add Controller and then type in the IP
    address of the machine you are running the controller (Step 6 aboe). Note that
    that the app suggests port 8080 but you actually need to use port 8688 (ex
    ). You don’t need to fill out any of the other fields, just click save. The app
    will try to connect to the controller and will show a green check mark if
    successful. If it doesn’t connect then either you don’t have the controller
    running on your PC or you have the wrong IP address set up in the app. If
    connected successfully to the controller, then exit the app and start it again
    and you should see a screen asking you to select the Panel you want to use and
    the application will launch. This is one of the Panels available in the designer.
    If after you set up the controller in the app you keep coming back to the app configuration
    screen when the app starts up, delete the controller and add it back again.

Hope this helps other beginners!