Simple http commands

Hi there!
Trying to switch my zwave devices via HTTP, like:[51].instances[0].SwitchBinary.Set(255)

Works fine in any browser - works NOT on Openremote.

What am I doing wrong?

Allready tried the different “HTTP Methods”


All http request in a browser use a GET

sample command http request -

This is what I use to control one lamp (screenshots attached)

3 x Commands

  • Lamp On

  • Lamp Off

  • Lamp Status

1 x Sensor

  • to use the status

1 x switch

  • to tie them all together

Hope this helps

Thanks for trying!
Does not work 4me… :frowning:

How do I have to translate this for openremote??

Like I said --> works in the browser like a charm![71].SwitchBinary.Set(255)

I suspect that Openremote is encoding the URL to something like this[71].SwitchBinary.Set(255)

Is your zwave device reacting to this? You can use for testing.

Anyway, if your device does not support encoded URLs then you can workaround this by putting a curl command in a shell script and use shell-execution protocol for calling them. You can pass parameters with ${param}

This way you can support protocols which are not directly available in Openremote. For example, some time ago I’ve implemented Smappee interface

Smappee implements oauth2 token authentication, which currently is not available in Openremote out of the box.

Kind regards,


Message posted on behalf of PZ1

Please look into my RaZberry manual page
    A work around for this problem is there.
    Further discussions with me should go on the forum

Thanks for your reply!
“Unfortunately” I´m on a PC.

And the installation is on another system/ip in my network.

So I´m trying to link that installation with openremote via http commands.

(which work perfect - executed through a browser)

I´m not familiar with “shell execution” - there has to be an easy way!!

THX in advance!

Hi Michal,
the decoded url worked fine in the browser - but sadly not on OR.

I´m not familiar with shell execution…

But thanks anyway!!

Greetz Lee