Subscribe Attribute does nothing


Sorry if the question may seem to be quite trivial but I am a completely new at this (but very eager to learn!!)

I have followed the tutorial on how to connect a MQTT client and I have managed to write attributes using format that were numerical, text and JSON (see figure attached)

Now I have two questions. The first one is less relevant but I basically cannot enable the subscribe attribute.
I have tried to enable it using different methods that I have found online. I am not sure if I am using the wrong topic or the wrong command. These are the topic template that I have tried:
TOPIC: realm_name/mqttclientid/attribute/attribute/deviceid (given in the GitHub wiki)
realm_name/mqttclientid/attributevalue/attribute/deviceid (I have found this online)

CMD: “true” to try to enable the subscribe attribute but also 1 was tried and nothing has been working.
I get an error message “Disconnected from server”

I thought that the subscribe attribute needed to be on for me to be able to send in message but even when disabled I am still managing to send in messages to the other attributes so I assume that it is not needed…?
(in this case I manually enabled it)

I am using MQTT Explorer to send in commands (not sure if it is relevant).

Let me know if anything is unclear or if it needs additional information.

Hi Casentiv,

for me, it’s a little bit unclear what you try to achive.

on your screenshot: you want to send true/false to the attribute “Subscribe attribute” over mqtt explorer?
then you should use this format:

1 Like

Hi Denis,

Thank you, that worked!

1 Like

You‘re welcome! Have fun!