velserv and openremote

hi everyone,
since about a year i’ve got a velbus system and openremote operational and worked great until a few days ago it stopped .

After a few hours of searching and not finding the issue i decided to reinstall my raspberry pi 3 , velserv and openremote.

The installation wend pretty smooth …, i thougt .

Openremote works , i can sync .

Velserv works , i can connect VelbusLink through the server with my velbus.

Could someone give me a clue what i’m missing .

thanks to everyone who’s willing ( and who’s not) to give me a hand with it.

greatings steven


Of course I'm happy to help. :slight_smile:

What symptoms have you got that indicate the link isn't working between OpenRemote and VelServ?

Which port are you using to connect VelbusLink to your Pi?

Have you downloaded the latest version of OpenRemote? (Which contains a new version of the Velbus jar file, which in turns takes longer to complete the startup process to greatly reduce failed initialisations)

Can you confirm the address and port settings for Velbus in your OpenRemote design please.

Please excuse any slow replies, I'm working on a site with a very limited internet connection.

hi Stuart,
the symptoms ? i can’t interact with the velbus on my smartphone , no temperature , response of relay outputs…

which version of openremote , i believe 2.6.0 wich was given in the download link on the github page

i placed the velbus 1.3.1.jar file into the /webapps/contoller/WEB-INF/lib and deleted older versions




That's cool.

A complete lack of communication points me to the basic link between OpenRemote and VelServ.

(You could have been suffering a wholly new set of symptoms)

At least this way we're looking for something straightforward.

So to start with...

You should know that my machines here are all working with the official release version V2.5, but I did try V2.6beta and didn't have any trouble.

Which leads me back to the main link again.

Can you try changing the address in your OpenRemote configuration to look at or localhost ?

This should eliminate any network issues outside of your Raspberry Pi.

It might be worth doing some minor edit to your UI, just to make sure the address change is committed to the config download.

If it still doesn't make a connection, double check that the entry is correct in controller.xml, it should be at the end of the file somewhere.

The next step is to use the logging tab in VelbusLink to watch the traffic as OpenRemote starts.

Please let me / us know how you get on.


Hi Stuart,
some great news , i’ve got it back running.

i checked those steps and every thing looked ok, then i diceded to install chromium on the raspberry and did the usual upgrade’s, wich i did also before, and out of the blue it come back running, the only thing i need to find out now is how to run the velserv on reboot.

I tried to use “crontab @reboot” ,but no luck, if you have any suggestions ?

already thanks for the support


Hi Stuart,
i shouted victory to early .

but i think i know where the problems started, i’ve got another raspberry pi lying around ,for playing and testing, and it seems there is also a velserv installed on it (previous copy of SD card) and when i plugged in ,even when the good one unplugged , the problems start.

when i restart the velserv on the good one i’am getting " velserv = error binding the server"

could it be mac issue ?

OK ,now it’s working ,
solved by removing openremote 2.6.0 and installing 2.5.0 and had it working in 10 minutes.

for starting the velserv on reboot i used “crontab”, made a shell script and added to crontab @reboot sh /path to script

Hi Steven

Thanks for the great feedback.

I'm sorry you've experienced some issues.

It's probably worth reaching out to the author of VelServ via

He's an extremely pleasant chap, I'm sure he'll help you.