zwave values

My multi sensor send temperature like this: Node ‘7:0’ : [COMMAND_CLASS_SENSOR_MULTILEVEL::SENSOR_MULTILEVEL_REPORT, Value=‘16.4’, Type=‘AIR_TEMPERATURE’
but the sensor value is truncated to 16 is there away to get the decimal?

I've noticed that level sensor types only like whole numbers, have you tried creating a custom sensor?

Good luck


Yes I tried the custom sensor, results seem to be rounded as well

The sensor types ‘Level’ and ‘Range’ are based on integers that means numbers without fractional digits. The Z-Wave implementation rounds a sensor value before a sensor of type ‘Level’ or ‘Range’ is updated. Unfortunately it seems that a custom sensor is also updated with the rounded value. I’ll fix that so that a custom sensor can be used to show sensor values with fractional digits. The fix will be included in the next Z-Wave version.

Hi Rainer

Is the next version out yet? If so where do I download from?


I think that there is no new OpenRemote controller version out that contains the new Z-Wave version but you can download it separatley : Z-Wave 3.3.0

This new version should resolve the custom sensor issue that you’ve encountered. You have to replace the existing Z-Wave library in the directory /webapps/controller/WEB-INF/lib.

Thanks Rainer
That works perfectly although I had to add a function to check if the number was an integer then add “.0” so the number was consistent