Assets not part of realms

Hello there,

Fresh install without visible issues on VPS.

My issue is, i’ve set up mqtt agent to external mosquitto broker and asset url’s parts are said to be topics to publish to be client. I’ve created an asset and in the url no realm is showing, so i can not publish to it directly. Looks like the asset is not part of the realm.

In realms, the list is empty, and in keycloak the realm is there.

Do any of you have any idea where to go next? Started with a fresh os for a couple of times and clean install, still the same happening.

Thanks in advance:


screenshot 2 as one allowed per post for newbies.

screenshot 3

I also face this issue , i followed below steps to fix it
1.docker-compose down
2.service docker restart
3. docker-compose pull
4. docker-compose -p openremote up


Giving it a try, thank you!

it did return : proxy container unhealthy, encountered some errors while bringing up the project. that is weird, because only manager was updated and now i don’t even have any response in browser…

any ideas?

Yes pls share screenshot of error .

manager seems to be always starting and running not more then a coupe of seconds

You need to update ur yml file

Basically you have to edit 3 lines

Then pull the image


Actually i’ve found this thread, but can’t see a difference, mine already looks like this except that I’m running it on a vps so DOMAINNAME, KC_HOSTNAME, OR_HOSTNAME are pointing to my VPS’s ip.

Pulled the image, even restarted docker, still proxy unhealthy, however under new id, so the pull went well.



This line should added in 3 volume

OR_STORAGE_DIR exists which by default is /storage in the manager container; you can add a volume to the docker compose file to create this path as shown in our own docker-compose.yml (note the assignment of the manager-data in the manager service as well as being defined at the top of the compose file.

yep, they’re in and have been there already…

Then check the docker log for better understanding.


Make sure all the 3 lines are there, I had the same issue and fixed it with these lines.
You are looking for:
-line 12 manager-data:
-line 41 - manager-data:/storage
-line 85 - manager-data:/storage
line numbers are based on github yml that apurba posted

Yeeej, thank you it works now. Thank you all!

1 Like

All right, the issue comes back when I install Mosquitto aside on the vps. It was all fine until Mosquitto and before I was always installing Openremote afterwards Mosquitto.

Any clues?

All right, what am I doing wrong, fresh install on a fresh vps, no mosquitto.

Looks fine, realms show in realms list in manager, I can create a new one, however when I create a new asset the URL doesn’t contain realm name.

What I do is:

sudo -i

apt-get update

apt-get upgrade


apt-get install docker-compose

sudo nano docker-compose.yml

change DOMAINNAME, KC_DOMAINNAME, OR_HOSTNAME to my subdomain which the ip is routed to


KEYCLOAK_FRONTEND_URL=MY_SUBDOMAIN/auth docker-compose -p openremote up -d

am i doing it wrong?

Can you share a screenshot of the issue? I’m not understanding this part

Yes, sure.

As you can see the url doesn’t include the realm name and for me to be able to publish to the asset from the client it would be needed. Looks like the asset is not part of the realm.

for publish ------>realm_name/mqttclientid/writeattributevalue/attribute/deviceid
for subscribe ------>realm_name/mqttclientid/attributevalue/attribute/deviceid

You can see the realm name in the 3 dots on top right → realms
So in your cause to publish is (supposing your realm name is fatslashblack)

I also don’t understand what are you trying to do with mosquitto
Consider that OpenRemote has an internal MQTT broker, so from your client you can just use the above topic to the MQTT broker on port 8883 with a service user and his secret