Authentication logo


I would like to know how to change the authentication page logo. I found out how to change home page logo but not the authentication logo.

You can edit the keycloak themes-template.

@Denis , @Don Thanks for your answer.
I tried this option by adding a keycloak-theme.json file and using the default theme that I copied to the deployment folder but I don’t see any changes.

Here is my json file
“themes”: [{
“name” : “ENVIRO”,
“types”: [ “login”, “email”, “account” ]

You don’t need to add the json file.

download the templates and copy them to your deployment folder:


in the login folder, there is a template.ftl, which you can edit.

The OpenRemote Logo is implemented as a SVG.

Beginning at Line 33 to 40


Thanks @Denis ,
I did what you said but There is no change even if I change the favicon.png.

Did you restarted the docker compose and deleted the browser cache? (CTRL + F5)

Yes, It’s not working

Could you check in Keycloak whether the theme is actually set to the realm your accessing? > administration console > select realm > ‘theme’ in the horizontal tab bar > select the correct theme, ‘ENVIRO’ I guess? If its not, select it and save it and see if its working now.

I followed these steps exactly, and even if I leave the template.ftl unmodified the login page looks like this:

this is my deployment folder structure:


Hey @cheezymcsquibble
I want to know what’s going on with your problem cause I have the same problem and not solved it yet

It seems to me that there could be a folder missing or the custom deployment isn’t able to access the styling elements for some reason.

Are you make adding for a custom asset in the portal ?


Did you verify in the keycloak portal if the theme is available?

hi Don,

I only have the ‘master’ realm, and in there I have the ‘base’ selected. If I choose ‘Openremote’ I get this as theme:

Thats what you added right? So seems to be working. Now you can try to modify the images/colors.

Also, on the realms page you can set the login theme without having to go into the keycloak console.

It doesn’t take any of my changes into consideration though; for example I added my own favicon to the /img folder and renamed the original one. Then I restarted docker, cleared my browser cache but still no change

Also, these are the theme options I see in keycloak:

I think you are missing a folder in your structure there. In ‘themes’ you should add a folder with your theme, lets say ‘cheezy’, which has account, email, login. Then cheezy should show up in keycloak theme select.

Could you try that?

Now we’re talking! the favicon is working now, I’ll try changing some other stuff to see if it works. Basically this is the correct folder structure, as you said:

Hey @cheezymcsquibble ,
how do you get to this dropdown menu?