Cannot connect to the mqtt client

I am not able to connect to mqtt client. I am doing all the steps given here Tutorial: Connect your MQTT Client · openremote/openremote Wiki · GitHub but cannot connect to the mqtt. I am using a self signed SSL certificate.

what error are you getting?

The problem with port 1883 has been resolved but I cannot publish anything when I want to publish I get an error “disconnected from server”

“writeAttribute” is my attribute name
This is my configuration on openremote


I think the wiki guide is pretty clear about the topic needed to publish attribute events (there is no realm:user in the topic just realm the realm:user string goes in the username and then password is your service user secret.

The realm name is master itself. IIIOT is the friendly name given to it

And even if I change it to IIIOT It doesn’t work

I have followed the steps given in wiki changed the realm:user to realm but its still not working

I am getting this error now

You seem to be jumping between publishing and subscribing; the topic format for both is defined in the wiki, some key points:

  • Make sure the realm is correct
  • Make sure the asset ID and attribute name is correct (case sensitive)
  • Make sure the client ID in the topic matches your MQTT client client ID (some clients have an option enabled by default to append timestamp to the client ID so you need to disable that)

Look at the logs of the or-manager-1 container for information about failures.

change it to attribute=attributevalue

Post pictures for user option in master. And also post yml file here

docker-compose.yml .txt (2.3 KB)

So, after successfully connected (mqttexplorer with openremote)

and i have observed that you created a attribute , name “writeAttribute” is Number type attribute and when you send data from mqttexplorer send data
So, you are getting disconnected error .

to fixed this issue First,

set topic for publish data — master/client987/writeattributevalue/writeAttribute/deviceid

this client987 – cliend id should be match , pls match the same

then click on “Advance” tab and check the id

and here i able to send data in sub attribute below

Second, change mqttexplorer to MqttBox (get software from store)
this one

it might solve your problem.

1 Like

I have done all the steps you have mentioned but it is only showing the data in history which I publish and data is still not subscribing and I still get the “disconnected from server” error.

And I also cannot find mqttbox for ubuntu 22.04

choose JSON and sent data.


We can see from your history that you are unable to connect to the MQTT server. This could happen for a variety of reasons. What I can suggest is going through the logs of the “manager” Docker container, when you send the publish message to the server and when you subscribe to a topic (which means when you press connect to the MQTT server and when you publish a message to it). Searching for “MQTT” may help. The Docker container may have some useful information. Please let me know what information you get.

Two things that I would just like to double-check:

  • Do you have the keycloak and proxy containers running?

  • Have you given sufficient permissions to the service user you are using?

Please let me know when you get the Docker container logs.

All the best,


I have sent data in all three formats but its showing the same error

Keycloak and proxy containers are running fine and service users have sufficient permissions but still getting this error

Can you please send the logs of the Manager docker container? This will probably help us pinpoint the issue. Maybe there are also some logs in the Manager UI, in the settings on the upper-right corner.

log.yml.txt (77.4 KB)